Page 1 of 1

Smart card login problem

Posted: 2019/10/23 23:02:38
by lo1ol

I've some problem with login via smart card to the system. I have some pam module which I configured and test. It works with su and sudo programs, but it doesn't work with login.

I type "autoconfig --enablesmartcard" (in GUI I didn't find how to activate smartcard login) and configured pam by adding to the top of system-auth file and now it's look like this:

Code: Select all

# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth	      sufficient pkcs11_module=/usr/lib64/ # here is my pam module
auth        required
auth        required delay=2000000
Also, I tried to add the same line to the smartcard-auth and fingerprint-auth file, because I noticed in syslog, that, when I login the service fingerprint is activated. it didn't help. The smart card login didn't started.

Can you help me to configure smart card login in CentOS 7?

P.s. I tried smart card login in last version of GosLinux, which based on CentOs 6, and login worked. Furthermore, I have the opportunity to activate login via smart card in GUI.

Re: Smart card login problem

Posted: 2019/10/29 19:40:27
by lo1ol
Also, I have noticed that smart card authentication is successfull in the KDE