New Install No Ethernet

Issues related to configuring your network
Post Reply
Posts: 1
Joined: 2020/12/12 01:36:47

New Install No Ethernet

Post by barnmichael » 2020/12/12 01:42:27

New install of CentOS-7 minimal install on new computer. Went well, but no Ethernet. tried nmtui to set up network. No Ethernet device listed. Good light on switch, blinking yellow light on computer. Tried 'ip a' and it only shows the loopback. Tried lspci and got "command not found".

So, how do I get networking working on CentOS-7?


User avatar
Forum Moderator
Posts: 30173
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: New Install No Ethernet

Post by TrevorH » 2020/12/12 02:58:42

Start with lspci -nn | grep -i net to get the PCI vendor/device ids and then check with grep -i $vendor /lib/modules/$(uname -r)/modules.* | grep -i $deviceid (substitute using your vendor/device ids before you run that) to see if there is a module that supports it already in the supplied kernel. Probably not since it would be listed if there was. If not then you probably want to check the ELRepo yum repo and see if they offer a kmod package that supports your card.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Networking Support”