telnet to Cisco

Issues related to configuring your network
Post Reply
jbannister
Posts: 2
Joined: 2020/11/18 10:08:06

telnet to Cisco

Post by jbannister » 2020/11/18 10:12:27

Hi All,
I'm having an issue where when I configure telnet access on my Cisco router, access does not work from CentOS7 or CentOS8.
Note I have selinux and firewalld disabled.
Telnet does work using putty from my Windows machine. From CentOS the response is as follows:
[root@moodle ~]# telnet 192.168.1.102
Trying 192.168.1.102...
Connected to 192.168.1.102.
Escape character is '^]'.
Connection closed by foreign host.
Note there is a few secs delay before receiving the "Connection closed..." - Wireshark shows I'm receiving a TCP RST.
Any ideas?
Thanks in advance,
Jeff

User avatar
TrevorH
Forum Moderator
Posts: 29902
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: telnet to Cisco

Post by TrevorH » 2020/11/18 10:14:31

If the reject is coming from the far end then it's a Cisco problem though I'd question why you're using an outdated and insecure protocol to connect in the first place. Use ssh.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

jbannister
Posts: 2
Joined: 2020/11/18 10:08:06

Re: telnet to Cisco

Post by jbannister » 2020/11/19 03:15:59

Note: it also fails from ssh on CentOS in a similar way, i.e. RST

Post Reply

Return to “CentOS 7 - Networking Support”