fcoeadm: No action was taken

Issues related to configuring your network
Post Reply
sayeed4
Posts: 9
Joined: 2013/11/08 13:24:18

fcoeadm: No action was taken

Post by sayeed4 » 2020/03/21 15:37:22

Dear Experts,

Im trying to install fcoe on centos 7 but getting struck "fcoeadm: No action was taken"
Kindly help me to resolve this problem.


[root@test ~]# lspci | grep Network
03:00.0 Ethernet controller: Intel(R) 82599 10 Gigabit Dual Port Network Connection (rev 01)
03:00.1 Ethernet controller: Intel(R) 82599 10 Gigabit Dual Port Network Connection (rev 01)

[root@test ~]# modinfo ixgbe | grep ver
filename: /lib/modules/3.10.0-1062.12.1.el7.x86_64/updates/drivers/net/ethernet/intel/ixgbe/ixgbe.ko
version: 5.6.5
description: Intel(R) 10GbE PCI Express Linux Network Driver
rhelversion: 7.7
srcversion: 715C977D96EE6EAB55FA63B
vermagic: 3.10.0-1062.12.1.el7.x86_64 SMP mod_unload modversions
parm: MDD:Malicious Driver Detection: (0,1), default 1 = on (array of int)


[root@test ~]# yum install fcoe-utils lldpad

[root@test ~]# cd /etc/fcoe/
[root@test fcoe]# ll
total 8
-rw-r--r-- 1 root root 697 Mar 21 03:35 cfg-ens1f0
-rw-r--r-- 1 root root 677 Mar 20 18:08 cfg-ethx

[root@test ~]# vi cfg-ens1f0

## Type: yes/no
## Default: no
# Enable/Disable FCoE service at the Ethernet port
# Normally set to "yes"
FCOE_ENABLE="yes"

## Type: yes/no
## Default: no
# Indicate if DCB service is required at the Ethernet port
# Normally set to "yes"
#DCB_REQUIRED="yes"
DCB_REQUIRED="no"

## Type: yes/no
## Default: no
# Indicate if VLAN discovery should be handled by fcoemon
# Normally set to "yes"
AUTO_VLAN="yes"

## Type: fabric/vn2vn
## Default: fabric
# Indicate the mode of the FCoE operation, either fabric or vn2vn
# Normally set to "fabric"
MODE="fabric"

## Type: yes/no
## Default: no
# Indicate whether to run a FIP responder for VLAN discovery in vn2vn mode
#FIP_RESP="yes"


[root@test ~]# vi /etc/sysconfig/network-scripts/ifcfg-ens1f0

TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=ens1f0
UUID=67fc6be5-d315-4e75-9c22-e19db398f425
DEVICE=ens1f0
ONBOOT=yes
IPADDR=172.16.xx.xx
DNS1=172.16.xx.xx
PREFIX=24
GATEWAY=172.16.xx.xx


[root@test ~]# systemctl restart fcoe
[root@test ~]# systemctl restart lldpad
[root@test ~]# systemctl enable fcoe
[root@test ~]# systemctl enable lldpad

[root@test ~]# dcbtool sc ens1f0 dcb on
Command: Set Config
Feature: DCB State
Port: ens1f0
Status: Successful

[root@test ~]# dcbtool sc ens1f0 app:fcoe e:1
Command: Set Config
Feature: Application FCoE
Port: ens1f0
Status: Successful

[root@test ~]# ip link set dev ens1f0 up

[root@test ~]# systemctl restart fcoe

[root@test ~]# fcoeadm -i
fcoeadm: No action was taken
Try 'fcoeadm --help' for more information.

[root@test ~]# fcoeadm -i ens1f0
fcoeadm: No connection created on interface ens1f0
Try 'fcoeadm --help' for more information.

Post Reply

Return to “CentOS 7 - Networking Support”