Page 1 of 1

basic networking set up problem

Posted: 2020/01/05 20:52:14
by JPDoc
Hi All

I've set up a Dell m6800 laptop as dual boot win 10 and centos 7 (3.10.0-1062.el7.x86_64). The installation went fine but I've spent days trying to get networking going. I've set up the ethernet using Network Manager and it all seems ok, the status says connected but although I can ping the machines own IP address any pings to any other addresses including the gateway IP come back with "Destination host unreachable". I've spent days fiddling with this and haven't managed to get anywhere.

As I don't have ethernet to the machine in question I've had to manually type out the info below, apologies.

lspci | egrep -i -colour 'network|ethernet' returns

00.19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
03.00.0 Network controller: Broadcom Inc and subsidiaries BCM4352 802.11ac Wireless Network Adapter (rev 03)

Rooting around on the internet on a different machine I found information on elRepo that says that a driver for the Broadcom wireless adapter is a bit problematic due to Broadcom limitations on source code usage and that it needs compiling with every kernel update. So I've focused on the Intel Ethernet adapter to get some internet access, planning on working on the Broadcom issue when I'm actually online.

So I've set up the ethernet using the Network Manager (nmtui) with a static address of and a gateway of, dns and The interface used is em1.
Looking in /etc/sysconfig/network-scripts I can see that ifcfg-em1 seems to have all the right stuff in it -

UUID= " a long number"
HWADDR= " a mac address"

/var/resolve.conf is

Lspci -v reports the right ethernet controller (I217-LM) and says that kernel driver and module in use is e1000e which is I think correct. The network connection icon in the top right shows "Wired Connected". nmcli device status shows em1 as connected.

ifconfig -a shows em1 as
em1: flags=<UP, BROADCAST, MULTICAST,RUNNING,MULTICAST> mtu 1500 inet netmask broadcast
inet6 "a long number" prefixlen 64 scopeid 0x0<global>.

Route -a shows:
Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway UG 100 0 0 em1 U 100 0 0 em1 U 100 0 0 virbr0

My knowledge of networking is limited but I'm at a loss to see what is wrong. Again, I can ping the machine's own ip address and get a response but any other address on the local network gets "Destination host unreachable". Oh, and I need to use static IP for this system as my whole network is configured for this.

The ethernet card works fine under windows so I know the hardware is good. Any thoughts gratefully appreciated.

Thank in advance.

Re: basic networking set up problem

Posted: 2020/01/05 20:59:15
by TrevorH
Are you sure that is your gateway?

Re: basic networking set up problem

Posted: 2020/01/06 08:26:30
by JPDoc
Thanks for your interest. Yes - I have a fixed IP win10 machine and a fixed IP raspberry pi 3 on the same network and they are both using as a gateway and both work fine.

It's a bit complicated by the fact that there are two routers on this network - there is an ISP supplied router (ip that connects to the external internet and a second fritzbox router ( that uses the as a gateway. This is because the IP address of the supplied router is locked by the ISP and also I'd rather use the fritzbox for most things as it's a better unit, and it also gives me two wifi networks which helps as the house has thick granite walls.

So wired client machines connect to the fritzbox as a gateway and are then passed on to the ISP router. This hasn't been a problem for any other machine on the wired network. And the wifi phones, ipads etc all seem to work fine on DHCP.

I just noticed that I have mistakenly posted this on the centos8 networking support board and it should have been centos 7 - sorry about that, but I don't know how to move it to the correct board I'm afraid.

Re: basic networking set up problem

Posted: 2020/01/06 09:44:34
by JPDoc
I see that a vigilant admin has kindly moved my post to the centos7 networking section - thanks again!

A bit of further info - as a test I set the win10 machine to DHCP and it got an IP address immediately - and the gateway was set to So I booted it into centos7 and tried with that gateway - but no change, still "Destination host unreachable" on every ip address but its own, although it says it's connected.

So I set it to DHCP using the Network Manager gui brought up by clicking on the network connection icon in the top right (Gnome desktop). It sat there for a while with the message "connecting" then came up with "Failed to connect to network" and turned the wired adapter off. Rebooted into centos7 again just as a double check, same behaviour.

If I reset it to a fixed ip address with the gateway either or it again comes up with "connected" but I pinging any other address than its own gives "Destination host unreachable". I know the hardware works as it's ok in win10 and I'm assuming the e1000e driver is correct for centos7, so I'm a bit at a loss as to how to proceed . . .

Re: basic networking set up problem

Posted: 2020/01/06 15:01:37
by JPDoc
In order to try and get some network access I thought I'd try the method mentioned in this post


to get the wifi going and from there hopefully debug the ethernet. But I found that the default centos7 install formats everything to XFS and NTFS isn't installed by default and of course the host dual boot machine has NTFS on all partitions. I mucked around with making a small partition in win10 and formatting it to ext3 but that caused huge problems with the windows installation hanging completely. And with no ethernet or wifi and no spare usb stick where I am working I had no way to get the required rpms into the centos7 installation.

I had read that phone support was good in centos7, so I transferred the akmod-wl and broadcom-wl rpms from rpmfusion onto my android phone, and added the ntfs-3g-2017.3.23-11.el7.x86_64.rpm for good measure. Plugged the phone into the booted up centos7 and sure enough I was able to transfer the rpms into the centos install. Eureka thinks I.

But not so fast - when I tried to install the ntfs package using yum it went looking for a repo on the internet, which of course hung it up chasing various mirrors. So no ntfs. I then tried the akmod-wl rpm - also went looking for a repo and hung up. Same for the broadcom rpm.

So it would seem that to get the wifi internet connection working I already need to have a working internet connection. Sigh.

Re: basic networking set up problem

Posted: 2020/01/06 15:07:35
by TrevorH
yum --disablerepo=\* install /path/to/local.rpm

Re: basic networking set up problem

Posted: 2020/01/06 16:41:39
by JPDoc
Thanks so much, Trevor H - that was the key. Using the yum repo disable option I installed ntfs fine, and with that I could finally see the discs on the win10 partitions from Centos. So I loaded them up with the 4 rpms described in the post above (actually the EL7 versions, as the post was EL8) and installed them individually, then rebooted and viola both Broadcom wifi and bluetooth came up fine. I logged onto my local wifi and this post is coming from my spanking new centos7 install. Hurrah!

I've gone on to install the nvidia driver I need to work and a few other bits and bobs and it all looks good. Now that I can actually access the world my next stage is to try and figure out why the wired Intel ethernet isn't working even though it says it is. That'll be tomorrows task - any thoughts you have as to how to track it down would be gratefully appreciated.

And again, many thanks!

Just as an aside - when I was trying to yum install without the benefit of your disable option the yum command would go on searching for mirrors. I backgrounded it and tried to kill it with a "kill -9 %1" commend as "jobs" showed it as job 1, but I got a response that said something like "job 1 not found". Has the kill command changed syntax? Using the % sign to define the job number worked back in the BSD4.2 days and I thought it was still current. No big problem as I can still using the PID, I was just curious.

Re: basic networking set up problem

Posted: 2020/01/07 10:25:48
by JPDoc
Tracked down the issue with the wired ethernet - it was a problem with an external router, now resolved. So I've got full speed wired and wifi now working correctly, problem solved (hope it stays that way on the next kernel update). Many thanks again to TrevorH who put me on the right track.