Ethernet not detected

Issues related to configuring your network
Post Reply
Posts: 9
Joined: 2018/09/24 13:28:30

Ethernet not detected

Post by nishantvshah » 2018/09/24 13:43:59

Hello Forum,

Im a new user into linux and want to start learning centos to further sharpen my skills.

I have installed centos 7 on an old machine and the system does not seem to detect the eth adapter.

I have gone thru some posts but they dont seem to help much.

Here is some important info.

Uname -a = 3.10.0-862.el7.x86_64
I have tried to use both kmod-forcedeth-0.64-1.el7.elrepo.x86_64.rpm and also kmod-forcedeth-0.64-3.el7.elrepo.x86_64.rpm.

I tried the normal yum install and localinstall kmod........ But it failed as yum was trying to find an update repository.

I also tried the yum --disablerepo=\* install kmod...........

I get an error package kmod-forcedeth-0.64-1.el7.elrepo.x86_64

Requires kernel skb_clone_tx_timestamp = 0x83433c92
Installed kernel 3.10.0-862.el7.x86_64
kernel skb_clone_tx_timestamp = 0x251a2d2f

You could try using --skip broken to work around the problem
You could try running rpm -Va -nofiles -nodigest


User avatar
Retired Moderator
Posts: 3042
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland

Re: Ethernet not detected

Post by avij » 2018/09/24 14:01:23

Try a newer kmod-forcedeth -- kmod-forcedeth-0.64-3.el7_5.elrepo.x86_64.rpm seems to be installable on CentOS 7.5.

Posts: 9
Joined: 2018/09/24 13:28:30

Re: Ethernet not detected

Post by nishantvshah » 2018/09/24 14:28:38

Hello Avij

Thank you for your quick reply. I was wondering if it would make a difference if i grab the drivers from the vendor and install them ?

Is there an advantage to use elrepo ?


User avatar
Forum Moderator
Posts: 30337
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Ethernet not detected

Post by TrevorH » 2018/09/24 14:54:36

First are you sure you need the forcedeth driver? If you do then lspci -nn will list an nvidia ethernet card. Also, kmod-forcedeth has a kernel requirement so the 0.64-3.el7_5.elrepo version is the latest and needs you to be using the 3.10.0-862* series of kernels that come with 7.5. There is also a 0.64-3.el7.elrepo for 7.4 kernels (3.10.0-693*) and a 0.64-2.el7.elrepo for 7.3 (3.10.0-514*). You need to pick the right one for your currently running kernel then once ethernet is working, do a yum update to get to 7.5 and the 3.10.0-862.11.6 current kernel along with the matching kmod-forcedeth 0.64-3.el7_5.elrepo package.

Yes, kmod's from ELRepo have an advantage - they use the stable kernel ABI which means that you don't need to rebuild the driver every time the kernel changes - it's usually just on new point releases.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 9
Joined: 2018/09/24 13:28:30

Re: Ethernet not detected

Post by nishantvshah » 2018/09/24 15:43:10

Hello Trevor.

Yes i did the lspci -nn | grep -i net and did see a nvidia mpc61 10de:03ef ethernet adapter listed.

This is how i knew ill need the elrepo.. I havent tried the latest kmod-forcedeth.. Will do that in a while.

Also thanks for your input about elrepo being better.


Posts: 9
Joined: 2018/09/24 13:28:30

Re: Ethernet not detected

Post by nishantvshah » 2018/09/25 00:41:30

Thanks for the suggestions guys.. the issue was fixed by using a newer driver as suggested.

thanks again.


Posts: 2
Joined: 2020/06/04 16:52:32

Re: Ethernet not detected

Post by BitEater » 2020/06/04 17:02:44

I have the very same problem after installing centos 8 on an old PC:
no network but lspci shows me the nvida network adapter. ... 4.rpm.html

I moved the two files with the help of an usb stick to the new box but it
does not work because install howto 3. tries to download from internet.

The Problem is that this Box does not have Network !

So also a yum update or whatever will not function .

Thought that that onboard ethernet chip is supported since an ancient ubuntu 14.4.LTS had no problems
with an other copy of that mainboard :-(

Shall i user ubuntu, again, or go to freebsd ???

So what files do i need to download, copy per usb stick to that maschine and
in which order shall i install them with which commands ?

Remember that device has currently no network connection!

Thank you for your help.

Post Reply

Return to “CentOS 7 - Networking Support”