NIC adapaters missin for ROCKS - CENTOS 7.0 install

Issues related to hardware problems
Post Reply
rrpersaud
Posts: 1
Joined: 2020/09/05 14:26:36

NIC adapaters missin for ROCKS - CENTOS 7.0 install

Post by rrpersaud » 2020/09/05 14:37:16

Hello! I am wiping a scyld 5.0.6 cluster in favor of installing ROCKS 7.0 w/ CENTOS 7.0 that will be updated to 7.4 in a packaged roll. I am running into a major problem - during the installation process no NIC devices are being detected. The "Network & Hostname" section in the install is selectable, but empty.
Since this is my frontend node the following two devices SHOULD be detected:
09:00.0 Ethernet controller: Intel Corporation 82571EB/82571GB Gigabit Ethernet Controller D0/D1 (copper applications) (rev 06)
09:00.1 Ethernet controller: Intel Corporation 82571EB/82571GB Gigabit Ethernet Controller D0/D1 (copper applications) (rev 06)

Is this a driver issue? What do you guys think? The device was working fine 20 mins ago before I wiped the cluster. I've got no idea how to install a driver a prior to - well - installing an OS.
Is this more of a ROCKS question?

Thank you,
-R

User avatar
TrevorH
Forum Moderator
Posts: 29719
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: NIC adapaters missin for ROCKS - CENTOS 7.0 install

Post by TrevorH » 2020/09/05 15:57:05

Yes, it's more of a Rocks question. For a start, the very first question would be "why is Rocks not up to date and on 7.8"?

7.0 is ancient and dates from 2014 when it was first released. It is not safe to run.

7.4 is slightly better but really not much.. It dates from 2017 so is "only" 3 and a bit years out of date. It's still not safe to run.

If they cannot update in 3 years then I would not use it. Search for a different solution that actually cares about updates and security since these guys obviously don't.

You didn't include the -nn switch to lspci so it doesn't tell us the PCI Vendor/Device ids for those cards but 82571 is listed in /usr/share/hwdata/pci.ids with lots of id's and grep -i 8086 /lib/modules/$(uname -r)/modules.* | grep -iE "105e|105f|1060|10a0|10a1|10a4|10a5|10bc|10d5|10d9|10da" shows all of the ones that would be supported. Is yours in that list? Do you get results if you substitute your device id in the 2nd command?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

eyegor
Posts: 1
Joined: 2013/12/16 19:01:08
Contact:

Re: NIC adapaters missin for ROCKS - CENTOS 7.0 install

Post by eyegor » 2020/10/02 16:41:06

The lack of updated versions with the Rocks cluster distro has long been a pain to deal with. Earlier versions of the distro were a security nightmare.

While the initial installation of Rocks is based on CentOS 7.4, there are instructions on how to create new updates and OS rolls so you can keep the OS up-to-date. Unfortunately, the procedure for doing so is somewhat buried in the Rocks mailing list.

I just installed a Rocks 7 head node and once it was stable, I created a CentOS 7.8 OS roll and CentOS 7.8 Updates roll using the procedure outlined in:
https://marc.info/?l=npaci-rocks-discus ... 020062&w=2

Basically, you use the "rocks create mirror" command to download the essential bits from the OS and Updates repo and will end up with OS and Updates roll ISO files.

rocks create mirror <url that points to OS Packages directory> \
version=<OS Version> \
rollname=CentOS \
arch=x86_64

rocks create mirror <url that points to updates Packages directory> \
version=<YYYY-MM-DD> \
rollname=CentOS-7.8-Updates \
arch=x86_64

These will create two ISO files that can be added and enabled on the head node.

You'll need ~35 GB of space on the partition used to build the roll ISOs and enough space on your head node to ingest the two rolls.

My head node is a bit low on space, so I disabled and removed the CentOS 7.4 os and updates rolls, then added and enabled the 7.8 OS and updates roll.
Once that's done, you cd into the /export/rocks/install directory and run "rocks create distro".

When that was complete, I did a "yum clean all" and deleted the yum cache, then did a "yum check-updates" followed by a "yum -y update".

The head node rebooted and came back up cleanly. It now shows CentOS 7.8 and the newest vulnerability scan comes back with one "critical" that I'll patch when our updates mirror syncs.

I'm still in the process of preparing new compute nodes, so I've not kickstarted any nodes on the new head node. There's a possibility that I'll need to create a new kickstart image for the nodes, but that procedure is also defined in the rocks-list news list.

Post Reply

Return to “CentOS 7 - Hardware Support”