How to *actually* set keyboard layout to Italian?

Issues related to hardware problems
Post Reply
dolly
Posts: 17
Joined: 2018/01/01 09:32:25

How to *actually* set keyboard layout to Italian?

Post by dolly » 2020/08/08 14:27:58

Hello,
I'm running CentOS 7 on a dual-partitioned 64 bit Dell laptop.
I've connected an external keyboard, also by Dell but when I started typing I realized that instead of the Italian layout it has automatically adopted the US/UK layout.
I played around with localctl but to no avail -- after rebooting no changes can be noticed, the keyboard still leaves me a lame ducking.
This is the current situation:

Code: Select all

$ localectl 
   System Locale: LANG=it_IT.UTF-8
       VC Keymap: it
      X11 Layout: it
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp
$ 
Here's the contents of /etc/vconsole.conf :

Code: Select all

$ cat /etc/vconsole.conf 
KEYMAP=it
FONT=latarcyrheb-sun16
$
Next up:

Code: Select all

$ cat /etc/locale.conf 
LANG=it_IT.UTF-8
$ 
Finally:

Code: Select all

$ cat /etc/X11/xorg.conf.d/00-keyboard.conf 
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "it"
        Option "XkbModel" "pc105"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
$
I've also noticed that in the System's Settings > Region & Language , there's actually no Input Device (Language and Format are both set to Italy/Italian)-- is that how it's supposed to be?

It is painful to work in such conditions, considering that for some odd reason GNOME3 crashes the OS every time I press the Windows key thus forcing me to use GNOME Classic instead.
Can anyone help me out here, please?

George99
Posts: 66
Joined: 2013/09/08 17:01:05
Location: Germany

Re: How to *actually* set keyboard layout to Italian?

Post by George99 » 2020/08/09 14:49:27

dolly wrote:
2020/08/08 14:27:58
there's actually no Input Device (Language and Format are both set to Italy/Italian)-- is that how it's supposed to be?
No, really there should be one - depending on keyboard layout. Try to add it.

Post Reply

Return to “CentOS 7 - Hardware Support”