realtek and MAKE problems.

Issues related to hardware problems
Post Reply
The.Ex-pat
Posts: 22
Joined: 2019/06/21 00:07:29

realtek and MAKE problems.

Post by The.Ex-pat » 2020/07/10 02:04:16

This nic has a realtek chipset.
It's fighting me tooth and nail.
came with a unix driver.

Code: Select all

make clean modules
gives this error

Code: Select all

make -C src/ clean
make[1]: Entering directory `/home/ginRummy/r8169-6.013.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers rset modules.order Module.markers
make[1]: Leaving directory `/home/ginRummy/r8169-6.013.00/src'
make -C src/ modules
make[1]: Entering directory `/home/ginRummy/r8169-6.013.00/src'
make -C /lib/modules/3.10.0-1127.13.1.el7.x86_64/build SUBDIRS=/home/ginRummy/r8169-6.013.00/src modules
make: Entering an unknown directory
make: *** /lib/modules/3.10.0-1127.13.1.el7.x86_64/build: No such file or directory.  Stop.
make: Leaving an unknown directory
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/ginRummy/r8169-6.013.00/src'
make: *** [modules] Error 2
Edit:

Code: Select all

#
lspci -nn | grep -i net


00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)
01:0a.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller [10ec:8169] (rev 10)


Tried to install kmod-r8169 from El Repo too. No Dice!

User avatar
TrevorH
Forum Moderator
Posts: 29051
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: realtek and MAKE problems.

Post by TrevorH » 2020/07/10 08:33:34

What happened with kmod-r8169?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

The.Ex-pat
Posts: 22
Joined: 2019/06/21 00:07:29

Re: realtek and MAKE problems.

Post by The.Ex-pat » 2020/07/10 17:46:18

TrevorH wrote:
2020/07/10 08:33:34
What happened with kmod-r8169?
Nothing?? lol, I know that's the wrong answer.

terminal screen said kmodr* was installing. However, No change to the values in the OG post.

I haven't revisited the issue yet.
I was frustrated so I called it a night. I'm going to start google foo and t/e for a few hours.

side note: Every time I pull this box out of the closet and try to get it running. I give up. I'm determined to get it running this time.

The.Ex-pat
Posts: 22
Joined: 2019/06/21 00:07:29

Re: realtek and MAKE problems.

Post by The.Ex-pat » 2020/07/10 20:54:12

I loaded the module.
It came up.

thanks trevor

Post Reply

Return to “CentOS 7 - Hardware Support”