ASUS Prime X299 Deluxe II - Thunderbolt

Issues related to hardware problems
Post Reply
rfx74
Posts: 4
Joined: 2020/07/07 09:27:56

ASUS Prime X299 Deluxe II - Thunderbolt

Post by rfx74 » 2020/07/07 10:33:55

Hi all,
i've updated the kernel to the 5.7.x version, but i'm having problems with the thunderbolt support on CENTOS 7 with the Asus Prime X299 Deluxe II Motherboard.

On kernel 3.10.0-1127.13.1.el7.x86_64 i have this:
04:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
Kernel driver in use: pcieport
05:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
Kernel driver in use: pcieport
...
06:00.0 System peripheral: Intel Corporation JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018] (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8794
Kernel driver in use: thunderbolt
27:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
Kernel driver in use: pcieport
...
29:00.0 Multimedia video controller: Blackmagic Design UltraStudio 4K
Subsystem: Blackmagic Design UltraStudio 4K


On kernel 5.7.6-1.el7.elrepo.x86_64 i have this:
04:00.0 PCI bridge: Intel Corporation JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] (rev 06)
Kernel driver in use: pcieport
...
06:00.0 System peripheral: Intel Corporation JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018] (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8794
27:00.0 PCI bridge: Intel Corporation DSL5520 Thunderbolt 2 Bridge [Falcon Ridge 4C 2013]
Kernel driver in use: pcieport
...
29:00.0 Multimedia video controller: Blackmagic Design UltraStudio 4K
Subsystem: Blackmagic Design UltraStudio 4K

In the new kernel the thunderbolt is not detected (there is no kernel driver in use).
Can you help me fixing this?
Why the driver is not being loaded?

Thank you.
Luigi

rfx74
Posts: 4
Joined: 2020/07/07 09:27:56

Re: ASUS Prime X299 Deluxe II - Thunderbolt

Post by rfx74 » 2020/07/17 22:42:56

No one? :roll:

User avatar
TrevorH
Forum Moderator
Posts: 29051
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ASUS Prime X299 Deluxe II - Thunderbolt

Post by TrevorH » 2020/07/17 22:59:23

You're saying it doesn't work with the ELRepo kernel but does with the distro 3.10.0-1127.13.1.el7.x86_64 one? If so then that sounds like perhaps there is a missing module option in the ELRepo kernel config that needs to be turned on?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

rfx74
Posts: 4
Joined: 2020/07/07 09:27:56

Re: ASUS Prime X299 Deluxe II - Thunderbolt

Post by rfx74 » 2020/07/20 08:48:52

Hi TrevorH, first of all thank you for your answer.
Yes, it seems that in the latest ELRepo kernels the thunderbolt module is missing. Could you please help me to enable / install it? Or could you give me some advice where i can find some informations about it?
Thanks a lot.

User avatar
TrevorH
Forum Moderator
Posts: 29051
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ASUS Prime X299 Deluxe II - Thunderbolt

Post by TrevorH » 2020/07/20 08:53:51

It's something you need to talk to ELRepo about as they are not part of the CentOS Project itself. They have a mailing list and a bug tracker and I'd suggest you use one of those to discuss this with the people that produce the packages.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

rfx74
Posts: 4
Joined: 2020/07/07 09:27:56

Re: ASUS Prime X299 Deluxe II - Thunderbolt

Post by rfx74 » 2020/07/21 09:42:36

Thank you,
i'll try to contact them, hope to solve the problem.

Post Reply

Return to “CentOS 7 - Hardware Support”