Problem with installing Nvidia GT 630M (Dual card) on CentOS7

Issues related to hardware problems
Post Reply
ehsan.panahy
Posts: 3
Joined: 2016/11/30 20:46:27

Problem with installing Nvidia GT 630M (Dual card) on CentOS7

Post by ehsan.panahy » 2020/05/09 19:08:17

Hello anybody,
I used to install My graphic card easily by downloading Nvidia legacy driver(390.XX) and following the instructions from https://linuxconfig.org/how-to-install- ... os-7-linux.
But this time, after updating CentOS 7, it didn't go as i expected. There's no /etc/X11/xorg.conf by default, and when i try to create one by "nvidia-xconfig" command, a file like this will be created which unfortunately doesn't work :

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.132  (buildmeister@swio-display-x64-rhel04-14)  Fri Nov  1 05:15:46 PDT 2019

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
and here it is Xor.logs files =>
Xorg_logs.tar.gz
(3.37 KiB) Downloaded 23 times
can anybody help me please?
Last edited by ehsan.panahy on 2020/05/10 13:17:48, edited 2 times in total.

User avatar
jlehtone
Posts: 3099
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Problem with installing Nvidia GT 630M (Dual card) on CentOS7

Post by jlehtone » 2020/05/10 10:37:10

ehsan.panahy wrote:
2020/05/09 19:08:17
I used to install My graphic card easily by downloading Nvidia legacy driver(390.XX) and following the instructions.
The recommended method is to not download anything from NVidia, but to use the RPM-packaged drivers from ELRepo repository.
ehsan.panahy wrote:
2020/05/09 19:08:17
There's no /etc/xorg.conf by default
Or otherwise. The legacy config file is /etc/X11/xorg.conf
It is also possible to set only some sections of otherwise dynamic default configuration by dropping files into /etc/X11/xorg.conf.d/

ehsan.panahy
Posts: 3
Joined: 2016/11/30 20:46:27

Re: Problem with installing Nvidia GT 630M (Dual card) on CentOS7

Post by ehsan.panahy » 2020/05/13 12:36:24

Unfortunately /etc/X11/xorg.conf.d/ is also empty!.

Post Reply

Return to “CentOS 7 - Hardware Support”