Nvidia Twinview doesn't work with Quadro M4000 and RTX4000

Issues related to hardware problems
Post Reply
jeremyc
Posts: 1
Joined: 2020/04/30 12:16:16

Nvidia Twinview doesn't work with Quadro M4000 and RTX4000

Post by jeremyc » 2020/04/30 12:26:32

Hello

We use HP RGS to work remotely. We need to use twinview to connect 2 screens on workstations without screen connected.
This work fine with Quadro K2000 series but not with M4000 and RTX4000.

OS : Centos 7.7
Driver : 440.64
[ 6111.784] (II) NVIDIA(0): Using MetaMode string: “DFP-0: 2560x1440 +0+0, DFP-1:
[ 6111.784] (II) NVIDIA(0): 2560x1440 +2560+0”
[ 6111.784] (II) NVIDIA(0): Requested modes:
[ 6111.784] (II) NVIDIA(0): “DFP-0:2560x1440+0+0,DFP-1:2560x1440+2560+0”
[ 6111.785] (WW) NVIDIA(0): No valid modes for
[ 6111.785] (WW) NVIDIA(0): “DFP-0:2560x1440+0+0,DFP-1:2560x1440+2560+0”; removing.
[ 6111.785] (WW) NVIDIA(0):
[ 6111.785] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[ 6111.785] (WW) NVIDIA(0): “nvidia-auto-select”.
[ 6111.785] (WW) NVIDIA(0):
[ 6111.786] (WW) NVIDIA(0): No valid modes for
[ 6111.786] (WW) NVIDIA(0): “DFP-0:nvidia-auto-select,DFP-1:nvidia-auto-select”;
[ 6111.786] (WW) NVIDIA(0): removing.
[ 6111.786] (EE) NVIDIA(0): Unable to use default mode “nvidia-auto-select”.
[ 6111.786] (EE) NVIDIA(0): Failing initialization of X screen
[ 6111.882] (II) UnloadModule: “nvidia”
[ 6111.882] (II) UnloadSubModule: “glxserver_nvidia”
[ 6111.882] (II) Unloading glxserver_nvidia
[ 6111.882] (II) UnloadSubModule: “wfb”
[ 6111.882] (II) UnloadSubModule: “fb”
[ 6111.882] (EE) Screen(s) found, but none have a usable configuration.
xorg.conf

Code: Select all

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
EndSection
Section "ServerFlags"
	Option "BlankTime" "0"
	Option "StandbyTime" "0"
	Option "SuspendTime" "0"
	Option "OffTime" "0"
EndSection
Section "Device"
	Identifier  "Device0"
	Driver      "nvidia"
	VendorName  "NVIDIA Corporation"
        Option      "ConnectedMonitor" "DFP-0, DFP-1"
	Option      "CustomEDID" "DFP-0:/etc/X11/edid.bin; DFP-1:/etc/X11/edid.bin"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Device0"
	DefaultDepth     24
	Option "TwinView" "True"
        Option "MetaModes" "DFP-0: 2560x1440  +0+0, DFP-1: 2560x1440  +2560+0"
	SubSection "Display"
		Depth     24
	EndSubSection
EndSection

Post Reply

Return to “CentOS 7 - Hardware Support”