Page 1 of 1

Keyboard in virtual CentOS 7.7 stops responding or gives extra characters

Posted: 2020/04/24 20:47:58
by zitsky
I'm running Qemu on a Windows 10 laptop. Can't run Virtualbox because I'm not admin. Sometimes after I switch away and back to the VM the keyboard isn't recognized or I get things like ^[A ^[B... I immediately thought of the escape key but my keyboard works normally in Windows.

The only way to fix this is to reset/reboot the VM. Maybe next time I will try "clear" or "reset". However, when this happens I try to switch to another session (Ctrl-Alt-F2, etc) but I can't log in because I'm getting these extra characters.

If it matters I'm running CentOS 7.7 i386 (Alt Arch) for better performance under Windows x86_64. And this is in a text terminal since GUI is painfully slow.

I'm using this set up to learn PHP + MySQL.

I have no idea what causes this.

Re: Keyboard in virtual CentOS 7.7 stops responding or gives extra characters

Posted: 2020/04/25 00:44:44
by TrevorH
One of your Ctrl keys is stuck down. Press and release them each in turn to find out which one it was.

Re: Keyboard in virtual CentOS 7.7 stops responding or gives extra characters

Posted: 2020/05/05 20:18:06
by zitsky
I thought it might be that too, but it doesn't seem to fix it. I'll try again next time to see if I can fix it. Thank you very much for the reply.

Re: Keyboard in virtual CentOS 7.7 stops responding or gives extra characters

Posted: 2020/05/08 21:35:38
by zitsky
TrevorH wrote:
2020/04/25 00:44:44
One of your Ctrl keys is stuck down. Press and release them each in turn to find out which one it was.
I'm open to any other suggestions you might have. No problems in Windows. And this doesn't happen right away. It happens after about 30 minutes or so.

Re: Keyboard in virtual CentOS 7.7 stops responding or gives extra characters

Posted: 2020/05/20 15:55:50
by zitsky
Ignore this. This does not appear to be a solution. It doesn't consistently work. It could still be a problem with the keyboard.

(was Alt-PrintScrn)