"Ctrl+Shift" and "Ctrl+Alt" key combinations not working

Issues related to hardware problems
Post Reply
cwatson
Posts: 130
Joined: 2007/10/02 18:55:02

"Ctrl+Shift" and "Ctrl+Alt" key combinations not working

Post by cwatson » 2020/02/14 17:57:34

Hi, I'm not sure if this is the best sub-forum for the topic but since I booted up I can't make key combinations of "Ctrl+Alt+X" or "Ctrl+Shift+X" (where "X" is any other key). This includes some keyboard shortcuts I use (in Mate) and using e.g. "Ctrl+Shift+Tab" in Firefox.
I had previously done a small update but don't know what could have caused this. Here is some info:

Code: Select all

Linux localhost.localdomain 3.10.0-1062.9.1.el7.x86_64 #1 SMP Fri Dec 6 15:49:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Please note that I had updated to kernel 3.10.0-1062.12.1, but booted into the lower version in the case that the kernel update caused the issue.
The desktop environment I use is mate 1.16.

Here is a pastebin link with the yum packages updated in the past day or so: https://pastebin.com/VthETh8y
I am happy to provide any more information as required.

cwatson
Posts: 130
Joined: 2007/10/02 18:55:02

Re: "Ctrl+Shift" and "Ctrl+Alt" key combinations not working

Post by cwatson » 2020/02/23 16:42:03

I know this hasn't gotten any replies, but now an (the) issue seems to be that the shift, ctrl, and alt keys intermittently stop responding. Sometimes if I hold down left-shift for a few seconds it will work again (having seen someone suggest it e.g., here https://bugs.launchpad.net/ubuntu/+sour ... ug/1532746) but this is a very annoying issue to have especially since I use "tmux" constantly and need Ctrl+A.

Does anyone have any idea what could be wrong? Is this a hardware issue, the physical keys, a driver issue? This only started happening when I posted last week and I have had this latop for 3.5 years. The model is "HP ProBook 450 G3" serial number "5CD6228DXP". Thanks!

User avatar
TrevorH
Forum Moderator
Posts: 29113
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: "Ctrl+Shift" and "Ctrl+Alt" key combinations not working

Post by TrevorH » 2020/02/23 18:20:07

FWIW, I use MATE and have been running those 2 kernels for at least 3 weeks and have not yet seen a similar problem.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

cwatson
Posts: 130
Joined: 2007/10/02 18:55:02

Re: "Ctrl+Shift" and "Ctrl+Alt" key combinations not working

Post by cwatson » 2020/02/25 00:33:01

Thanks TrevorH; I figured it couldn't be a mate/shortcut issue once the keys stopped working intermittently from just single keystrokes. would a moderator be able to move this to the 'general support' sub-forum, or allow me to cross-post this, in the hopes it might get some more exposure? it's at the point where I am having trouble logging in because my password contains uppercase and special characters, and i don't know if the shift key registers.

thanks,
chris

P.S. I added "i8042.dumbkbd' to

Code: Select all

grub2-efi.cfg
per the launchpad bug link but it hasn't fixed the problem.

Post Reply

Return to “CentOS 7 - Hardware Support”