CentOS7 Raspberry Pi 4 4GB Support

Issues related to hardware problems
Posts: 1
Joined: 2020/04/03 14:00:26
Location: France

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by swixkot » 2020/04/03 16:37:15

pgreco wrote:
2019/09/08 13:06:31
ftimmers wrote:
2019/09/07 21:35:50
I managed to put the root-partition on a ssd and boot it. Also I tried to put this root-partition on LVM, but this did not work, so definitely I am doing something wrong. I tried to create a ramfs, but it doesn't work.
Can you give me a hint or put me in the right direction to make this work?
It may be that you're doing something wrong, but I have a feeling that is not the main problem :lol:
My (completely untested) theory is that since the rpi boots from a zImage generated at build time, instead of an initramfs generated at install time, the image doesn't include the necessary things to boot from LVM.
To confirm this, I'd need to build a kernel setting the correct conf to y instead of m (I think it is CONFIG_BLK_DEV_DM).
In the meantime, can you confirm that you can see the lvm once booted?
Like @ftimmers, I’m trying to put the root filesystem on LVM.
The boot process must include the LVM module in order to mount my root filesystem on the logical volume.
For this purpose, I modifed the /boot/cmdline.txt (changed root value) and I built a initramfs image with lvm and dm modules (i used dracut and /etc/dracut.conf)).

But, it seems impossible to request a boot with the use of initramfs. Adding initramfs instruction in the /boot/config.txt is without effect (besides, this file does not seem to be read.)

My question is: is it possible to activate the initramfs in the boot process ? If yes, how? If no, should we need a special kernel image with the LVM support? Maybe a such image already exists ?


(RPi4 model B 4GB RAM , CentOS-Userland-7-armv7hl-RaspberryPI-Minimal-4-1908-sda.raw.xz).

Posts: 1
Joined: 2020/04/05 18:07:47

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by xengi » 2020/04/05 18:16:11

I'm currently trying to get an aarch64 image running on the RPi4. Nice to hear that there already is some progress. Can you guys share how you create a CentOS image for the RPi4?

I'm currently creating one with Arch Linux ARM using the kernel and firmware packages from the AUR repo. Does CentOS have the proper RPi4 kernel and firmware files as packages somewhere or do I need to create those? I'm new to CentOS in that regard. So far I just used the installer on x86 targets.

Posts: 1
Joined: 2020/04/11 12:33:10

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by hostwap » 2020/04/11 12:36:20

Post Reply

Return to “CentOS 7 - Hardware Support”