CentOS7 Raspberry Pi 4 4GB Support

Issues related to hardware problems
swixkot
Posts: 1
Joined: 2020/04/03 14:00:26
Location: France

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by swixkot » 2020/04/03 16:37:15

pgreco wrote:
2019/09/08 13:06:31
ftimmers wrote:
2019/09/07 21:35:50
I managed to put the root-partition on a ssd and boot it. Also I tried to put this root-partition on LVM, but this did not work, so definitely I am doing something wrong. I tried to create a ramfs, but it doesn't work.
Can you give me a hint or put me in the right direction to make this work?
It may be that you're doing something wrong, but I have a feeling that is not the main problem :lol:
My (completely untested) theory is that since the rpi boots from a zImage generated at build time, instead of an initramfs generated at install time, the image doesn't include the necessary things to boot from LVM.
To confirm this, I'd need to build a kernel setting the correct conf to y instead of m (I think it is CONFIG_BLK_DEV_DM).
In the meantime, can you confirm that you can see the lvm once booted?
Like @ftimmers, I’m trying to put the root filesystem on LVM.
The boot process must include the LVM module in order to mount my root filesystem on the logical volume.
For this purpose, I modifed the /boot/cmdline.txt (changed root value) and I built a initramfs image with lvm and dm modules (i used dracut and /etc/dracut.conf)).

But, it seems impossible to request a boot with the use of initramfs. Adding initramfs instruction in the /boot/config.txt is without effect (besides, this file does not seem to be read.)

My question is: is it possible to activate the initramfs in the boot process ? If yes, how? If no, should we need a special kernel image with the LVM support? Maybe a such image already exists ?

swixkot

(RPi4 model B 4GB RAM , CentOS-Userland-7-armv7hl-RaspberryPI-Minimal-4-1908-sda.raw.xz).

xengi
Posts: 1
Joined: 2020/04/05 18:07:47

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by xengi » 2020/04/05 18:16:11

I'm currently trying to get an aarch64 image running on the RPi4. Nice to hear that there already is some progress. Can you guys share how you create a CentOS image for the RPi4?

I'm currently creating one with Arch Linux ARM using the kernel and firmware packages from the AUR repo. Does CentOS have the proper RPi4 kernel and firmware files as packages somewhere or do I need to create those? I'm new to CentOS in that regard. So far I just used the installer on x86 targets.

hostwap
Posts: 1
Joined: 2020/04/11 12:33:10

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by hostwap » 2020/04/11 12:36:20


markVnl
Posts: 4
Joined: 2019/08/29 22:35:36

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by markVnl » 2020/06/13 11:41:14

swixkot wrote:
2020/04/03 16:37:15
My question is: is it possible to activate the initramfs in the boot process ? If yes, how?
Hi swixkot,

Just encountered this lately..If you still searching for an answer :D
The "rasbian-based" kernel actually can boot into a initramfs if you edit config.txt and add (for the rpi4)

Code: Select all

[pi4]
initramfs <name_of_initramfs> followkernel

timuptocreate
Posts: 2
Joined: 2021/01/13 00:40:50

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by timuptocreate » 2021/01/13 01:01:09

ftimmers wrote:
2019/09/07 21:35:50
@pgreco, this image is working fine on my Pi4. Thank you for that!
I managed to put the root-partition on a ssd and boot it. Also I tried to put this root-partition on LVM, but this did not work, so definitely I am doing something wrong. I tried to create a ramfs, but it doesn't work.
Can you give me a hint or put me in the right direction to make this work?
how did you manage to boot Centos 7 from ssd.
Now is 2021, Raspberry updated rpi-eeprom.
Is very easy to boot Raspberry OS with USB drive. But I can't manage to boot Centos 7 minimal (but is booting with sd card)
It stops at
Waiting for root device /dev/mmcblk0p3...
random: fast init done
....
vcc-sd: disabling
random: crng init done
I've tried to change root in cmdline.txt from /dev/mmcblk0p3 to PARTUUID=f83320a7-02.

but it still fails
When I added initramfs <name_of_initramfs> followkernel

it said it can't find /dev/mmcblk0p3 , when changed cmdline.txt it could not find PARTUUID=f83320a7-02

pgreco
Posts: 31
Joined: 2018/04/14 17:23:02

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by pgreco » 2021/01/16 23:15:54

timuptocreate wrote:
2021/01/13 01:01:09
it said it can't find /dev/mmcblk0p3 , when changed cmdline.txt it could not find PARTUUID=f83320a7-02
Boot partition for partuuid is -03, not -02, you could also change it to /dev/sda3 (that's what I normally do)

timuptocreate
Posts: 2
Joined: 2021/01/13 00:40:50

Re: CentOS7 Raspberry Pi 4 4GB Support

Post by timuptocreate » 2021/01/23 06:24:14

pgreco wrote:
2021/01/16 23:15:54
timuptocreate wrote:
2021/01/13 01:01:09
it said it can't find /dev/mmcblk0p3 , when changed cmdline.txt it could not find PARTUUID=f83320a7-02
Boot partition for partuuid is -03, not -02, you could also change it to /dev/sda3 (that's what I normally do)
thanks pgreco
Going to cmdline.txt -> changing mmcblk0p3 to sda3 = it works

Post Reply

Return to “CentOS 7 - Hardware Support”