Intel graphics driver issue

Issues related to hardware problems
Post Reply
YKdev
Posts: 10
Joined: 2014/04/29 18:26:44

Intel graphics driver issue

Post by YKdev » 2016/08/23 15:03:19

Hello everyone. I need help with graphics driver installation.

I have a box with Intel Core i7 6700K and CentOS 7 installed. I need to install Intel graphics driver. How I found there's no video driver in use - "lspci -k". It doesn't show the string indicating the "kernel driver in use" for the "VGA compatible controller: Intel..."
I know there is "xorg-x11-drv-intel" package but it doesn't work. I have tried "yum update" - for no avail.
After searching the web I came across Intel Graphic Installer. But it refuses to work with CentOS (says "this distribution is not supported").

Does anyone know where to find a proper driver package?

YKdev
Posts: 10
Joined: 2014/04/29 18:26:44

Re: Intel graphics driver issue

Post by YKdev » 2016/08/31 06:37:17

Okay, there is no such package. And what are the options?

vladguan
Posts: 9
Joined: 2014/09/11 08:11:29

Re: Intel graphics driver issue

Post by vladguan » 2016/09/15 05:12:06

I have the same issue. Got a newish Gigabyte GA-Z170-D3H with Intel integrated HD graphics. lspci does not say that a kernel driver is in use. I do a yum install xorg-x11-drv-intel and it says that I already have the latest installed.

Package xorg-x11-drv-intel-2.99.917-8.20150615.el7.x86_64 already installed and latest version

I suspect that it is the integrated graphics that is causing my system to freeze after random amounts of idle time forcing me to press and hold the power button to shut it down.

giulix63
Posts: 1305
Joined: 2014/05/14 10:06:37
Location: GMT

Re: Intel graphics driver issue

Post by giulix63 » 2016/09/15 09:18:36

Several CentOS 7 users of latest Intel integrated GPUs (from Skylake/Gen9 on) have only had luck with more recent kernels. Like the one available from elrepo-kernel, kernel-ml, currently at 4.7.3.1.
Root is evil: Do not use root (sudo) to run any of the commands specified in my posts unless explicitly indicated. Please, provide the necessary amount of context to understand your problem/question.

cwatson
Posts: 130
Joined: 2007/10/02 18:55:02

Re: Intel graphics driver issue

Post by cwatson » 2016/09/19 18:37:55

You might try adding the following to your default boot parameters:

Code: Select all

i915.preliminary_hw_support=1
This worked for me with Intel Core i7-6500U

Post Reply

Return to “CentOS 7 - Hardware Support”