Page 1 of 1

3par - multipathd shows path status as orphan, faulty

Posted: 2015/04/27 18:47:55
by jab2805
Hi all,


I'm running CentOS 7.1. I has a basic san configuration brocade switches and Qlogic HBA's...
I copeid the multpath.conf file for the HP how to. The command "multipath -ll " returns no data. I can see the 3par and the export lun but multipath does not see it....



[root@lvxm1031 ~]# cat /etc/redhat-release
CentOS Linux release 7.1.1503 (Core)
[root@lvxm1031 ~]#

multipath -ll no data returned


orphan path:

[root@ ~]# multipathd -k
multipathd> show paths
hcil dev dev_t pri dm_st chk_st dev_st next_check
1:0:0:0 sda 8:0 1 undef ready running orphan
multipathd>



qlogic card:
looks good
[root@~]# dmesg | grep -E 'qla2xxx .* QLogic | Found an ISP'
[ 1.170699] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 8.07.00.08.07.1-k2.
[ 1.170968] qla2xxx [0000:05:00.0]-001d: : Found an ISP2532 irq 40 iobase 0xffffc9000606a000.
[ 3.898566] qla2xxx [0000:05:00.0]-00fb:0: QLogic QMH2572 - PCI-Express Dual Channel 8Gb Fibre Channel Mezzanine HBA, NFF.
[ 3.898760] qla2xxx [0000:05:00.1]-001d: : Found an ISP2532 irq 44 iobase 0xffffc900168fa000.
[ 6.625150] qla2xxx [0000:05:00.1]-00fb:2: QLogic QMH2572 - PCI-Express Dual Channel 8Gb Fibre Channel Mezzanine HBA, NFF.
[root@ ~]#




We can see 3par when we rescan:

[root@ ~]# scsi-rescan
Scanning SCSI subsystem for new devices
Scanning host 0 for all SCSI target IDs, all LUNs
Scanning for device 0 0 0 254 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 254
Vendor: 3PARdata Model: SES Rev: 3121
Type: Enclosure ANSI SCSI revision: 06
Scanning for device 0 0 1 254 ...
OLD: Host: scsi0 Channel: 00 Id: 01 Lun: 254
Vendor: 3PARdata Model: SES Rev: 3121
Type: Enclosure ANSI SCSI revision: 06
Scanning host 1 for SCSI target IDs 0 1 2 3 4 5 6 7, all LUNs
Scanning for device 1 0 0 0 ... 0 ...
OLD: Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor: HP Model: LOGICAL VOLUME Rev: 3.54
Type: Direct-Access ANSI SCSI revision: 05
Scanning for device 1 3 0 0 ... 0 ...
OLD: Host: scsi1 Channel: 03 Id: 00 Lun: 00
Vendor: HP Model: P220i Rev: 3.54
Type: RAID ANSI SCSI revision: 05
Scanning host 2 for all SCSI target IDs, all LUNs
Scanning for device 2 0 0 254 ...
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 254
Vendor: 3PARdata Model: SES Rev: 3121
Type: Enclosure ANSI SCSI revision: 06
Scanning for device 2 0 1 254 ...
OLD: Host: scsi2 Channel: 00 Id: 01 Lun: 254
Vendor: 3PARdata Model: SES Rev: 3121
Type: Enclosure ANSI SCSI revision: 06
Scanning host 3 for SCSI target IDs 0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 for SCSI target IDs 0 1 2 3 4 5 6 7, all LUNs
0 new or changed device(s) found.
0 remapped or resized device(s) found.
0 device(s) removed.

Re: 3par - multipathd shows path status as orphan, faulty

Posted: 2015/04/28 14:42:35
by jab2805
This is fixed. I changed my /etc/multipath.conf file:


From:
defaults {
polling_interval 10
user_friendly_names no
find_multipaths yes
}
devices {
device {
vendor "3PARdata"
product "VV"
path_grouping_policy group_by_prio
path_selector "round-robin 0"
path_checker tur
features "0"
hardware_handler "1 alua"
prio alua
failback immediate
rr_weight uniform
no_path_retry 18
rr_min_io_rq 1
detect_prio yes
# fast_io_fail_tmo 10
# dev_loss_tmo 14
}
}



To:
defaults {
polling_interval 10
max_fds 8192
}
devices {
device {
vendor "3PARdata"
product "VV"
no_path_retry 18
features "0"
hardware_handler "0"
path_grouping_policy multibus
getuid_callout "/lib/udev/scsi_id --whitelisted --device=/dev/%n"
path_selector "round-robin 0"
rr_weight uniform
rr_min_io_rq 1
path_checker tur
failback immediate
}
}
blacklist {
devnode "^sda$"
}


multipath -ll:

# multipath -ll
Apr 28 10:43:41 | multipath.conf +13, invalid keyword: getuid_callout
360002ac0000000000000005a00002960 dm-5 3PARdata,VV
size=2.0T features='1 queue_if_no_path' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=1 status=active
|- 0:0:0:0 sdb 8:16 active ready running
|- 2:0:0:0 sdd 8:48 active ready running
|- 0:0:1:0 sdc 8:32 active ready running
`- 2:0:1:0 sde 8:64 active ready running