CentOS won't boot after installing ATI drivers fglrx-x11-drv

Issues related to hardware problems
Post Reply
linuxnewb
Posts: 52
Joined: 2015/03/10 08:48:41

CentOS won't boot after installing ATI drivers fglrx-x11-drv

Post by linuxnewb » 2015/04/17 02:56:35

Hi,

I installed the AMD Catalyst drivers on CentOS 7 using the following:

Code: Select all

yum --enablerepo elrepo-testing install fglrx-x11-drv
The install process was successful but reported a possible conflict with xorg-x11-glamor, so I removed xorg-x11-glamor with the following:

Code: Select all

yum remove xorg-x11-glamor
I rebooted the system and it hangs at a black screen with a non-blinking cursor after briefly flashing a few lines of msgs including something like:

Code: Select all

/sbin/fsck.xfs: XFS file system.
3.170371] [drm:radeon_init] *ERROR* No UMS support in radeon module!
Thanks in advance for any help.

linuxnewb
Posts: 52
Joined: 2015/03/10 08:48:41

Re: CentOS won't boot after installing ATI drivers fglrx-x11

Post by linuxnewb » 2015/04/17 07:13:05

Hi,

I managed to login with the CentOS installation disk to repair, and then uninstalled the fglrx-x11-drv drivers. This has enabled me to boot and login again but now I can't see any way to re-enable my dual monitor setup. The KDE Display Configuration only shows one monitor and it is locked at 1024x768 rez. I'm not sure where to go from here. :(

linuxnewb
Posts: 52
Joined: 2015/03/10 08:48:41

Re: CentOS won't boot after installing ATI drivers fglrx-x11

Post by linuxnewb » 2015/04/21 02:26:35

Resolution:

The source of the issue is a bug in the fglrx drivers as referenced here and also here. The issue remains open but the solution is to add the following to xorg.conf:

Code: Select all

Section "Files"
        ModulePath "/usr/lib64/xorg/modules/extensions/fglrx"
        ModulePath "/usr/lib64/xorg/modules"
EndSection
You may also need to edit /etc/default/grub and remove any reference to modeset or you'll get a UMS error when trying to boot. After editing /etc/default/grub regenerate grub.cfg with:

Code: Select all

grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg
Note: If you're not using a 64bit EFI system you will need to adjust the paths above.

Another 'gotcha' with installing fglrx on a 64bit system is that you also need to install the 32bit compatibility drivers. So you will need kmod-fglrx and fglrx-x11-drv and fglrx-x11-drv-32bit as referenced here. However the 32bit drivers wouldn't install from the repo they suggest so I got them from 'elrepo-testing'.

I hope this saves someone from a world of pain. :)

Post Reply

Return to “CentOS 7 - Hardware Support”