[solved]Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Issues related to hardware problems
Post Reply
Klaus69
Posts: 28
Joined: 2006/01/20 13:51:08

[solved]Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by Klaus69 » 2015/04/05 06:36:27

Hi,

i upgraded from CentOS7 to 7.1. Before the upgrade i could use my internal Intel 3945ABG wifi adapter without any issues.
Now it looks likethere is a problem with the driver for this hardware.

Network Manager shows device PCI unknown with the mac address of the wifi nic. But tit` s grey.

lspci shows 0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Paket iwl3945-firmware-15.32.2.9-36.el7.noarch in newest version is installed


modinfo iwl3945
filename: /lib/modules/3.10.0-229.1.2.el7.x86_64/kernel/drivers/net/wireless/iwlegacy/iwl3945.ko
firmware: iwlwifi-3945-2.ucode
license: GPL
author: Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version: in-tree:ds
description: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux
rhelversion: 7.1
srcversion: 74607945F172262E502CED2
alias: pci:v00008086d00004227sv*sd*bc*sc*i*
alias: pci:v00008086d00004222sv*sd*bc*sc*i*
alias: pci:v00008086d00004227sv*sd00001014bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001044bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001034bc*sc*i*
alias: pci:v00008086d00004222sv*sd00001005bc*sc*i*
depends: iwlegacy,cfg80211,mac80211
intree: Y
vermagic: 3.10.0-229.1.2.el7.x86_64 SMP mod_unload modversions
signer: CentOS Linux kernel signing key
sig_key: 34:B5:BC:A2:B7:06:D8:2E:72:A5:BE:3E:E4:09:BE:C7:19:5E:A5:08
sig_hashalgo: sha256
parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm: swcrypto:using software crypto (default 1 [software]) (int)
parm: disable_hw_scan:disable hardware scanning (default 1) (int)
parm: debug:debug output mask (uint)
parm: fw_restart:restart firmware in case of error (int)

modprobe iwl3945 seems to load the driver

because

lsmod
Module Size Used by
iwl3945 104771 0
iwlegacy 132381 1 iwl3945
mac80211 569655 2 iwl3945,iwlegacy
cfg80211 514740 3 iwl3945,iwlegacy,mac80211
...

modprobe -r iwl3945 removes the entry with the unknown pci device out of network manager and modprobe iwl3945 brings it back.

dmesg
[ 478.799479] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
[ 478.799485] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 478.799550] iwl3945 0000:0c:00.0: can't disable ASPM; OS doesn't have ASPM control
[ 478.840280] iwl3945 0000:0c:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 478.840287] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 478.840366] iwl3945 0000:0c:00.0: irq 43 for MSI/MSI-X
[ 478.842899] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 478.863584] systemd-udevd[4000]: renamed network interface wlan0 to wlp12s0
[ 478.880197] cfg80211: Calling CRDA for country: DE
[ 478.883437] cfg80211: Regulatory domain changed to country: DE
[ 478.883442] cfg80211: DFS Master region: unset
[ 478.883444] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 478.883449] cfg80211: (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 478.883452] cfg80211: (5150000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 478.883456] cfg80211: (5250000 KHz - 5350000 KHz @ 80000 KHz), (N/A, 2000 mBm), (0 s)
[ 478.883459] cfg80211: (5470000 KHz - 5725000 KHz @ 80000 KHz), (N/A, 2698 mBm), (0 s)
[ 478.883462] cfg80211: (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 731.564096] perf interrupt took too long (2507 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 2629.206288] perf interrupt took too long (5003 > 5000), lowering kernel.perf_event_max_sample_rate to 25000

May be there is something with the newer NetworkManager? Dont know how to get the version from CentOS 7.0 for testing.

Any hints what to do?

Thanks in advance:
Klaus

EDIT: Tried different usb wlan adapter ( based on different ralink chipsets eg ra2870 ) which are supported. They are seen in dmesg and lsusb but are also "unknown" in networkmanager. I lso own a aavmUSB ritz WLAN but do not know how to move on from cd rom mode. Any tut available ?
Last edited by Klaus69 on 2015/04/29 16:46:23, edited 1 time in total.

bgilbert73
Posts: 5
Joined: 2015/04/24 20:37:15

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by bgilbert73 » 2015/04/24 20:40:16

I have the same issue and it is perplexing.

My issue however is this: It WORKED during the CentOS install. After reboot and upgrades, it showed unknown just like yours. My chipset is Atheros 9287.

Have you found anything since?

Brenden

User avatar
TrevorH
Forum Moderator
Posts: 29112
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by TrevorH » 2015/04/24 20:55:35

7.1 split the monolithic NetworkManager into several packages. Do your systems have NetworkManager-wifi installed?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

bgilbert73
Posts: 5
Joined: 2015/04/24 20:37:15

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by bgilbert73 » 2015/04/24 21:05:04

I'll go check and see.

Brenden

bgilbert73
Posts: 5
Joined: 2015/04/24 20:37:15

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by bgilbert73 » 2015/04/24 21:13:18

It didn't have it installed I did.

Installed:
NetworkManager-wifi.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7

My wifi card:

3: wlp9s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
link/ether 70:1a:04:8c:bd:12 brd ff:ff:ff:ff:ff:ff

nmcli device show:

GENERAL.DEVICE: wlp9s0
GENERAL.TYPE: wifi
GENERAL.HWADDR: 70:1A:04:8C:BD:12
GENERAL.MTU: 1500
GENERAL.STATE: 10 (unmanaged)
GENERAL.CONNECTION: --
GENERAL.CON-PATH: --
IP4.GATEWAY:
IP6.GATEWAY:

~]# nmcli device wifi rescan
Error: No Wi-Fi device found.

~]# nmcli device status
DEVICE TYPE STATE CONNECTION
virbr0 bridge connected virbr0
enp3s0 ethernet connected Profile 1
virbr0-nic tap connected virbr0-nic
lo loopback unmanaged --
wlp9s0 wifi unmanaged --

I am not sure what to do to make it managed, since it does not recognize it as a Wi-Fi device in spite of the driver installed and it being listed (ath9k driver)

~]# lsmod |grep ath9k
ath9k 136983 0
ath9k_common 25638 1 ath9k
ath9k_hw 450617 2 ath9k_common,ath9k
ath 29006 3 ath9k_common,ath9k,ath9k_hw
mac80211 569655 1 ath9k
cfg80211 514740 4 ath,ath9k_common,ath9k,mac80211

Brenden

bgilbert73
Posts: 5
Joined: 2015/04/24 20:37:15

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by bgilbert73 » 2015/04/24 21:15:39

network-scripts]# ifup wlp9s0
Error: no device found for connection 'FM292'.

ifcfg-wlp9s0:

HWADDR=70:1A:04:8C:BD:12
ESSID="FM292"
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME=FM292
UUID=92306dd1-9a46-4386-a49a-1320410091bc
ONBOOT=yes
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_PRIVACY=no

This was previously ifcfg-FM292 and working during installation.

Brenden

bgilbert73
Posts: 5
Joined: 2015/04/24 20:37:15

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by bgilbert73 » 2015/04/24 21:17:35

I realized I didn't restart NetworkManager after installing NetworkManager-wifi. It now works:

GENERAL.DEVICE: wlp9s0
GENERAL.TYPE: wifi
GENERAL.HWADDR: 70:1A:04:8C:BD:12
GENERAL.MTU: 1500
GENERAL.STATE: 100 (connected)
GENERAL.CONNECTION: FM292
GENERAL.CON-PATH: /org/freedesktop/NetworkManager/ActiveConnection/2
IP4.ADDRESS[1]: 192.168.1.7/24
IP4.GATEWAY: 192.168.1.1
IP4.DNS[1]: 192.168.1.1
IP4.DOMAIN[1]: home
IP6.ADDRESS[1]: fe80::721a:4ff:fe8c:bd12/64
IP6.GATEWAY:

Thanks for the help Trevor! :)

Brenden

User avatar
toracat
Forum Moderator
Posts: 7439
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by toracat » 2015/04/24 21:29:58

That is all good, but we have yet to hear from the OP, Klaus69.
CentOS Forum FAQ

Klaus69
Posts: 28
Joined: 2006/01/20 13:51:08

Re: Upgrade to 7.1 => Intel 3945ABG WiFi no more working

Post by Klaus69 » 2015/04/29 08:49:22

Sorry had been on business travel. Your suggestion was right and solved the issue.

May be it would be helpfull if it would be checked during installation / upgrade if wifi hardware is available?

Many thanks for your support.
Would it be okay if i would ask you something about a RAID Controller which worked in CentOS6 but does not in CentOs 7 / 7.1 ?

User avatar
TrevorH
Forum Moderator
Posts: 29112
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: [solved]Upgrade to 7.1 => Intel 3945ABG WiFi no more wor

Post by TrevorH » 2015/04/29 17:01:32

New subjects are best addressed in a new thread but there is a section of the RHEL 7 release notes that deals with RAID controllers which have been deprecated since RHEL6.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Hardware Support”