Network issue IRQpoll crashing

Issues related to hardware problems
Post Reply
Slimzy
Posts: 5
Joined: 2014/10/17 18:34:47

Network issue IRQpoll crashing

Post by Slimzy » 2015/02/19 21:12:49

Hello all !

i got an issue ATM i have to reboot my "server" at least once a day to patch the problem and it's kind of annoying ! it's only one network card that is affecte out of 2 ( dhcp server) so the actual card is a D-Link DGE-530T Rev. C1 .

the issue is causing a major latency on my network going from 0 MS as ping to 1s as ping .... if anyone have an idea please share :) i've tried many way to install driver reset the card OS repair ... nothing have permanently solved it !

NedSlider
Forum Moderator
Posts: 2896
Joined: 2005/10/28 13:11:50
Location: UK

Re: Network issue IRQpoll crashing

Post by NedSlider » 2015/02/26 11:15:10

I've had a quick look at the upstream driver code in the latest kernel, and whilst there are a few new commits I didn't see anything that sounded like it might fix your issue. However, you could try elrepo's latest kernel-ml package to see if the updated driver fixes the issue. If it does I can probably backport the fixes for you into a kmod driver for the distro kernel.

But without wanting to sounding defeatist, if it's causing you that much hassle for the sake of $20 I would simply replace the card with something that works reliably (an Intel chipset maybe?).

Slimzy
Posts: 5
Joined: 2014/10/17 18:34:47

Re: Network issue IRQpoll crashing

Post by Slimzy » 2015/02/28 21:44:37

well yeah it slow down my network quite a lot and the worst is that if i roll back on other distro like debian or roll back on centos 6.11 or later well the problem isn't there so im wondering why i'm having the issue only on RHEL 7 distro .

Slimzy
Posts: 5
Joined: 2014/10/17 18:34:47

Re: Network issue IRQpoll crashing

Post by Slimzy » 2015/02/28 22:15:19

tried a forced kernel update but needed to add --skip-broken at the end of it now running on kernel 3.19 ( at the moment problem seems solved but gonna update in a few hour to see).

Post Reply

Return to “CentOS 7 - Hardware Support”