Cups 1.6 & Network printer issue

Issues related to hardware problems
Post Reply
Posts: 7
Joined: 2008/11/05 08:49:47
Location: Czech Rep.

Cups 1.6 & Network printer issue

Post by kovalja » 2015/02/12 21:08:43

Hi folks,

I'm trying to setup under my newly installed CentOS 7 two printers connected through print servers. For simplicity I will just talk only about 1 of these 2 printers as the issue and symptoms are exactly the same for both of the printers.

My setup contains HP LJ1100 connected to print server Edimax PS-1206P. Everything worked fine on old Mandriva or CentOS 6.5 until I installed CentOS 7 with cups 1.6. When I setup the printer directly through standard GUI and use socket: or ipp: or lpd: the printer prints always only few lines on the first page and then it prints empty sheets of paper. I tried to debug it and therefore setup exactly the same way the printer under CentOS 6.5 with cups 1.4 where printing worked fine out of the box without issue. So it's not the print server to be blamed. It leads me to cups 1.6 issue.

My question is if anybody of you encountered such an issue with network printers and cups 1.6. Did anybody of you have such problems and did anybody resolve that?

N.B. For many years I was using paid Turboprint and wanted to use it now as well. So I purchased the latest version and setup printers as they were setup on older OS and the behaviour is the same as described above. Only few lines are printed and then many blank sheets.

Thanks for your advice,

Post Reply

Return to “CentOS 7 - Hardware Support”