[SOLVED] CentOS 7.0 on Intel NUC

Issues related to hardware problems
Posts: 76
Joined: 2013/03/04 13:17:23

[SOLVED] CentOS 7.0 on Intel NUC

Post by username » 2014/07/18 08:22:42


Yesterday, I tried to install CentOS 7.0 with the default Gnome 3.8 on a Intel NUC (DN2820FYKH, a low cost Celeron, here are the specs : http://www.intel.com/content/www/us/en/ ... 0fykh.html). EDIT : I previously updated the NUC with the latest BIOS released the 05/13/2014, here https://downloadcenter.intel.com/Search ... rodId=3782

I wasn't able to boot with the system with default kernel. After selecting the kernel on the grub menu, it immediately displays an error message [0.000000] tsc : Fast TSC calibration failed (which seems pretty much harmless from what I read on various forums) and a gray screen. Then, it hangs there indefinitely.

I could only boot Centos 7.0 on rescue mode. This time, it displayed the same calibration error message followed by this :

Code: Select all

*ERROR* Cannot initialize the agpgart module.
DRM: Fill_in_dev failed.
Then, it seemed to boot normally (I didn't see any errors in the boot.log). But, the whole system was very slow (especially compared with Fedora 20, which runs like a breeze on the same NUC with Gnome 3.10). I updated CentOS and rebooted but the issue persist.

It makes me wonder :
Is it a kernel issue ? Maybe the 3.10 kernel doesn't really support well the Bay Trail processors.
Or maybe its the Mesa driver fault ?

In both cases, it doesn't seems I can do much about it... Using different kernels or Intel drivers would probably ruin the whole stability advantage of using CentOS...

Has somebody succeeded in running CentOS 7.0 on a similar NUC ?
Last edited by username on 2014/10/27 16:45:25, edited 2 times in total.

User avatar
Forum Moderator
Posts: 31067
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7.0 on Intel NUC

Post by TrevorH » 2014/07/18 08:44:54

Hit tab on the initial install menu and remove "quiet" from the end of the line then press enter. Now you can see the entire boot log and get more details about where it hangs.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 76
Joined: 2013/03/04 13:17:23

Re: CentOS 7.0 on Intel NUC

Post by username » 2014/07/18 09:23:44

Okay :

Code: Select all

Initializing XFRM netlink socket
NET : Registered protocol family 10
NET : Registered protocol family 17
Loading compiled-in X.509 certificates
Loaded X.509 cert 'CentOS Linux kpatch signing key: [here is the key]'
Loaded X.509 cert 'CentOS Linux Driver update signing key: [here is the key]'
Then it hangs...

Posts: 8
Joined: 2014/07/19 21:40:39

Re: CentOS 7.0 on Intel NUC

Post by Atomic234 » 2014/07/19 22:12:19

I'm not using the same hardware, but I couldn't get CentOS 7 to install at all on an ASRock Q1900 motherboard. I logged a bug report here: http://bugs.centos.org/view.php?id=7405

Posts: 7
Joined: 2014/07/19 20:37:00

Re: CentOS 7.0 on Intel NUC

Post by wchao » 2014/07/25 13:03:19

I'm using the Gigabyte Intel Celeron N2807 Mini PC Barebones GB-BXBT-2807
http://www.gigabyte.com/products/produc ... id=5038#ov
http://www.amazon.com/gp/product/B00KR0 ... UTF8&psc=1

I get a very similar problem during install. I see the error message "tsc : Fast TSC calibration failed" and then it just hangs during install.

If one of the developers wants a system to test on, I'd be happy to ship a unit for the person to borrow for a few weeks if that is helpful for solving this particular problem in the install. I don't know if it's an incompatibility with Bay Trail as the first poster hypothesized, but it's possible given the similarity (yet difference) in hardware.

CentOS 6.5 installs just fine on the machine. I'd love to get CentOS 7 working on it though, since I don't want to be installing old software on new machines.

Posts: 1
Joined: 2014/07/31 12:25:24

Re: CentOS 7.0 on Intel NUC

Post by makosteel » 2014/07/31 12:38:37

I managed to install CentOS 7.0 on a Intel NUC DN2820FYKH by disabling the high precision event timer in the legacy settings of the BIOS.

Ultimately unsuccessful as I managed to boot up once to perform a YUM update, rebooted then I froze at the same regardless of the BIOS setting, which I switched to see if it had an effect.

Turning off quiet on the GRUB line revealed that it was hanging on the x.509 certificate signing, for which I have found no bypass, even rescue mode does not get pass it.

I have the 0038 version of the BIOS (latest at time of writing), and other OS's seems to boot with no issue Ubuntu 14 live being the only one I have tested so far.

as for the clock sources that Ubuntu could see was tsc, hpet, acpi_pm and Ubuntu was using tsc with the high precision event timer setting switched on in the BIOS.

can anyone else suggest what else to look for/at?

Posts: 1
Joined: 2014/08/02 05:54:09

Re: CentOS 7.0 on Intel NUC

Post by whzzz28 » 2014/08/02 05:59:42

Would also like to report the same issues as Makosteel with my DN2820FYKH with CentOS 7.
However i am unable to install at all.

Normal method of install results in two penguins in the top left of the screen and then nothing. Keyboard/mouse are locked out and have to hold the power button to shut down.
Removing quiet from the boot lines i can see that it gets to the line:
"Loaded X.509 cert 'CentOS Linux kpatch signing key: <random numbers>"
where it stops.

I have tried turning off high precision timers but without luck.
I am using the latest BIOS version from Intel.

I tried the latest Debian netinstall ISO and it worked no problems.
CentOS netinstall and minimal fail in the same way.

Any suggestions?

Posts: 1
Joined: 2014/08/03 01:24:51

Re: CentOS 7.0 on Intel NUC

Post by etm1109 » 2014/08/06 02:44:04

Ive seen this problem on an HP Workstation XW8200. I've tried for a week to get Centos 7.0 running after running 6.5for six months. In my case, the system fails upon launching Firefox. Tried loading and running updates. Got lockups in the updates. Upon multiple restarts and hanges, I see that message. About ready to punt...

Posts: 1
Joined: 2014/08/02 16:42:17

Re: CentOS 7.0 on Intel NUC

Post by rewse » 2014/08/19 14:30:32

I’ve succeeded in installation on my Intel NUC DN2820FYKH and it’s running fine.
The solution is written on my blog because it's a little complicated. I hope this will helps you.

Posts: 76
Joined: 2013/03/04 13:17:23

Re: CentOS 7.0 on Intel NUC

Post by username » 2014/10/24 16:36:00

Somebody else succeded to install Centos 7.0 on a NUC or a Brix ?

I've just tried rewse workaround with the latest BIOS update (v40) on the NUC DN2820FYKH but it still doesn't work for me.

I've the same problem with the Gigabyte Brix GB-BXBT-2807.

EDIT : Finally it works ! At the grub menu, I edited the kernel command line : I removed the quiet parameter and I added the parameter intel_pstate=disable.

Then it boots normally...

Post Reply

Return to “CentOS 7 - Hardware Support”