Onborad Intel Graphics card not recognized in CentOS 7.9.2009

Issues related to hardware problems
Post Reply
siliconvlsi
Posts: 2
Joined: 2022/08/02 12:29:42

Onborad Intel Graphics card not recognized in CentOS 7.9.2009

Post by siliconvlsi » 2022/08/02 13:12:51

I am installing CentOS 7.9.2009 on a Acer Intel i5 desktop with Intel H510 Chipset.
The onboard graphics is a Intel UHD Graphics 730 Chipset.

After installation the X-server comes up in a 800x600 resolution without any other option.

When I check the Xorg.0.log (see attached) I see the following errors:

[ 17.078] (EE) open /dev/dri/card0: No such file or directory
[ 17.078] (WW) Falling back to old probe method for modesetting
[ 17.078] (EE) open /dev/dri/card0: No such file or directory
[ 17.078] (II) Loading sub module "fbdevhw"
[ 17.078] (II) LoadModule: "fbdevhw"
[ 17.078] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 17.078] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 17.078] compiled for 1.20.4, module version = 0.0.2
[ 17.078] ABI class: X.Org Video Driver, version 24.0
[ 17.078] (EE) Unable to find a valid framebuffer device
[ 17.078] (WW) Falling back to old probe method for fbdev
[ 17.078] (II) Loading sub module "fbdevhw"
[ 17.078] (II) LoadModule: "fbdevhw"
[ 17.078] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 17.078] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 17.078] compiled for 1.20.4, module version = 0.0.2
[ 17.078] ABI class: X.Org Video Driver, version 24.0
[ 17.078] (II) FBDEV(2): using default device
[ 17.078] vesa: Refusing to run on UEFI
[ 17.078] (EE) Screen 0 deleted because of no matching config section.
[ 17.078] (II) UnloadModule: "modesetting"
[ 17.078] (EE) Screen 0 deleted because of no matching config section.
[ 17.078] (II) UnloadModule: "fbdev"
[ 17.078] (II) UnloadSubModule:
Xorg-trim.0.log
"fbdevhw"


When I check the directory /dev, there is no dri directory

Any help on debugging this problem will greatly be appreciated.

Thank you in advance.
Attachments
Xorg-trim.0.log
(7.16 KiB) Downloaded 6 times

User avatar
TrevorH
Forum Moderator
Posts: 32133
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Onborad Intel Graphics card not recognized in CentOS 7.9.2009

Post by TrevorH » 2022/08/02 14:51:49

Your card has PCI Vendor device ids 8086:4c8b and it is not supported by the CentOS 7 kernel module. Edit: RHEL 7 is out of the phase of support where RH add new hardware so it is unlikely to be supported on el7 at all.

This is the output from the same commands on CentOS 7 vs Rocky 8:

Code: Select all

[root@centos7 ~]# grep -i 8086 /lib/modules/$(uname -r)/modules.* | grep -i 4c8b
[root@centos7 ~]# 

[root@rocky8 tmp]# grep -i 8086 /lib/modules/$(uname -r)/modules.* | grep -i 4c8b
/lib/modules/4.18.0-372.13.1.el8_6.x86_64/modules.alias:alias pci:v00008086d00004C8Bsv*sd*bc03sc*i* i915
So on el7 that card is not supported but on el8 it is. It's also supported on Rocky 9 and on Fedora 36.

I see a few possibilities:
Install a different, supported, graphics card
Reinstall in Legacy BIOS mode and use the 'vesa' driver - I assume that would work and give you more resolutions but is likely to be slow. The current message says " [ 17.078] vesa: Refusing to run on UEFI"
Install and use ELRepo's kernel-ml or kernel-lt (assuming that -lt is new enough to have support, it may not)
Install and use one of the newer distros mentioned above.
CentOS 8 died a premature death at the end of 2021 - migrate to Rocky/Alma/OEL/Springdale ASAP.
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 and 6 are dead, do not use them.
Use the FAQ Luke

siliconvlsi
Posts: 2
Joined: 2022/08/02 12:29:42

Re: Onborad Intel Graphics card not recognized in CentOS 7.9.2009

Post by siliconvlsi » 2022/08/04 09:52:45

Thank you very much @TrevorH
We just bought 12 of those PCs so changing the graphics card may not be out first option.
First we will try reinstalling in BIOS mode with VESA driver. If that fails, Rocky 8 maybe the next option.
Thank you again.

Post Reply