GeForce RTX 2070 / HDMI issues

Issues related to hardware problems
Post Reply
jjw
Posts: 7
Joined: 2019/10/30 06:40:05

GeForce RTX 2070 / HDMI issues

Post by jjw » 2021/05/29 09:52:21

Hello,

I have an issue with Centos 7.

I use a GeForce RTX 2070 and three monitors (AOC 2775, 2x Samsung LS32R750Q). Two via hdmi and two via display port.

I have to unplug and plug in the HDMI to have the monitor recognized. There is a screen display per se, in the sense that the desktop is extended to the three, just that the HDMI is blank. If I unplug the HDMI and reinsert it restarts again. After screen lock (after 5 min inactive), the HDMI goes down again. Then another plug-out/plug-in is required to have it going again.

Tried swapping monitors. Tried swapping cables.

I (re)installed what I believe is the latest version of the driver.

Works well in Windows.

Any ideas on where to start debugging, thanks?

Code: Select all

> cat /etc/centos-release
CentOS Linux release 7.9.2009 (Core)

> uname -r
3.10.0-1160.25.1.el7.x86_64

> nvidia-smi 
| NVIDIA-SMI 460.80       Driver Version: 465.31       CUDA Version: 11.2     |

bonedome
Posts: 198
Joined: 2017/04/22 08:11:04

Re: GeForce RTX 2070 / HDMI issues

Post by bonedome » 2021/06/07 08:43:30

Sorry can't help with the driver but I disable my screensaver with

Code: Select all

xset -dpms s off
If you must have a screensaver maybe a keyboard shortcut to the xrandr command used to set the 3 screens

Code: Select all

xrandr -q
will show your current setup and options.

Post Reply

Return to “CentOS 7 - Hardware Support”