Boot Problem

Issues related to applications and software problems
Post Reply
codigus
Posts: 4
Joined: 2021/01/19 19:41:07

Boot Problem

Post by codigus » 2021/01/19 19:43:43

Hi all,

I have a dedicated server with centos 7 in OVH. I changed root password in rescue mode and now the server doesn't boot. Only in rescue. Anyone can help me?

Server is configured in Raid 0.

Thank you all

User avatar
TrevorH
Forum Moderator
Posts: 30314
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Boot Problem

Post by TrevorH » 2021/01/19 21:43:43

You corrupted the selinux context on /etc/shadow when you changed the password in rescue mode. Reboot and append enforcing=0 to the kernel command line and it will boot in permissive mode and should come up normally. Once booted, login and run restorecon -RFv /etc/shadow /etc/passwd and that should fix the problem properly. Try another reboot and see if it comes back up without intervention.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

codigus
Posts: 4
Joined: 2021/01/19 19:41:07

Re: Boot Problem

Post by codigus » 2021/01/20 13:04:51

Do you want to help me? I will pay for the job.

User avatar
TrevorH
Forum Moderator
Posts: 30314
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Boot Problem

Post by TrevorH » 2021/01/20 15:26:01

I just spoonfed you the answer to your problem. I'm certainly not going to logon to your server and fix it and you shouldn't let anyone else that you don't know personally (i.e "I know where you live!") do so for you either.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

codigus
Posts: 4
Joined: 2021/01/19 19:41:07

Re: Boot Problem

Post by codigus » 2021/01/20 15:47:52

I just need to solve my problem. I don't have nothing to hide. 😊

codigus
Posts: 4
Joined: 2021/01/19 19:41:07

Re: Boot Problem

Post by codigus » 2021/01/20 17:32:53

now i am getting this message;

Image

Post Reply

Return to “CentOS 7 - Software Support”