Google chrome issue in CentOS 7 platform

Issues related to applications and software problems
Post Reply
testuser
Posts: 1
Joined: 2020/11/09 10:49:23

Google chrome issue in CentOS 7 platform

Post by testuser » 2020/11/09 11:11:19

-If we set up google-chrome as default browser and try to hit any URL through any third party application it throws sandbox errors on terminal console and it observed for root user only
-It fails to open chrome and throws running as root without --no-sandbox is not allowed.
-This issue is resolved only by adding --no-sandbox flag to exec of file /usr/bin/google-chrome
-By doing this it open chrome but still throws warnings and errors on terminal or console

This issue is observed on all versions of CentOS 7 platform an with latest stable chrome build.
Attachments
Errors with sandbox flag added
Errors with sandbox flag added
with-sandbox.png (33.26 KiB) Viewed 83 times
Errors without sandbox flag added
Errors without sandbox flag added
without-sandbox.jpg (31.63 KiB) Viewed 83 times

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Google chrome issue in CentOS 7 platform

Post by TrevorH » 2020/11/10 10:21:42

This is a chrome problem that you need to ask them about.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

bonedome
Posts: 181
Joined: 2017/04/22 08:11:04

Re: Google chrome issue in CentOS 7 platform

Post by bonedome » 2020/11/18 21:38:28

Why are you trying to run a browser as root, my version of Chrome works fine if I run it as user.
If you are unable to create a user for some reason, I'd try another browser, the firefox binary works on puppy linux (root only OS)

Post Reply

Return to “CentOS 7 - Software Support”