snapd update error

Issues related to applications and software problems
Post Reply
mrajaeim
Posts: 2
Joined: 2020/04/17 05:30:29

snapd update error

Post by mrajaeim » 2020/10/31 09:33:30

snapd packages need update:
---> Package snap-confine.x86_64 0:2.45.3.1-1.el7 will be updated
---> Package snap-confine.x86_64 0:2.47.1-1.el7 will be an update
---> Package snapd.x86_64 0:2.45.3.1-1.el7 will be updated
---> Package snapd.x86_64 0:2.47.1-1.el7 will be an update
---> Package snapd-selinux.noarch 0:2.45.3.1-1.el7 will be updated
---> Package snapd-selinux.noarch 0:2.47.1-1.el7 will be an update

error:
Error: Package: snapd-selinux-2.47.1-1.el7.noarch (epel)
Requires: selinux-policy-base >= 3.13.1-268.el7
Installed: selinux-policy-targeted-3.13.1-266.el7_8.1.noarch (@updates)
selinux-policy-base = 3.13.1-266.el7_8.1
Available: selinux-policy-minimum-3.13.1-266.el7.noarch (base)
selinux-policy-base = 3.13.1-266.el7
Available: selinux-policy-minimum-3.13.1-266.el7_8.1.noarch (updates)
selinux-policy-base = 3.13.1-266.el7_8.1
Available: selinux-policy-mls-3.13.1-266.el7.noarch (base)
selinux-policy-base = 3.13.1-266.el7
Available: selinux-policy-mls-3.13.1-266.el7_8.1.noarch (updates)
selinux-policy-base = 3.13.1-266.el7_8.1
Available: selinux-policy-targeted-3.13.1-266.el7.noarch (base)
selinux-policy-base = 3.13.1-266.el7

my selinux-policy-base version:
Package selinux-policy-targeted-3.13.1-266.el7_8.1.noarch already installed and latest version

tunk
Posts: 832
Joined: 2017/02/22 15:08:17

Re: snapd update error

Post by tunk » 2020/10/31 12:31:04

Looks like selinux-policy-targeted-3.13.1-268 is part
of CentOS 7.9, which isn't released yet. You can get
it by enabling the CR repo.

mrajaeim
Posts: 2
Joined: 2020/04/17 05:30:29

Re: snapd update error

Post by mrajaeim » 2020/10/31 13:43:59

thanks. I will wait for official release.

User avatar
TrevorH
Forum Moderator
Posts: 29915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: snapd update error

Post by TrevorH » 2020/10/31 13:50:06

The official release will be no different to CR, it's just that you can have CR now rather than waiting.

yum --enablerepo=cr update
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”