cant open settings, update issue!?

Issues related to applications and software problems
Post Reply
quik
Posts: 2
Joined: 2020/08/28 20:52:26

cant open settings, update issue!?

Post by quik » 2020/08/28 20:59:01

I have an issue with centos 7, I have a GUI installed (GNOME). When i click on settings in the menu, the cursor changes to a wheel but nothing happens. after a few seconds, it switches back to the regular cursor.
There seem to be issues with updating as well (see log below).
I tried these 3 commands, but didnt help either: yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last"

any other suggestions?

[root@v2202002112998107844 ~]# yum update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centosmirror.netcup.net
* epel: mirrors.n-ix.net
* extras: mirror.alpix.eu
* updates: centosmirror.netcup.net
Resolving Dependencies
--> Running transaction check
---> Package ca-certificates.noarch 0:2019.2.32-76.el7_7 will be updated
---> Package ca-certificates.noarch 0:2020.2.41-70.0.el7_8 will be an update
---> Package grub2-tools.x86_64 1:2.02-0.80.el7.centos will be updated
---> Package grub2-tools.x86_64 1:2.02-0.86.el7.centos will be an update
---> Package initscripts.x86_64 0:9.49.47-1.el7 will be updated
---> Package initscripts.x86_64 0:9.49.49-1.el7 will be an update
---> Package iptables.x86_64 0:1.4.21-33.el7 will be updated
---> Package iptables.x86_64 0:1.4.21-34.el7 will be an update
---> Package logrotate.x86_64 0:3.8.6-17.el7 will be updated
---> Package logrotate.x86_64 0:3.8.6-19.el7 will be an update
---> Package mongodb-org-server.x86_64 0:4.2.5-1.el7 will be updated
---> Package mongodb-org-server.x86_64 0:4.2.9-1.el7 will be an update
---> Package polkit.x86_64 0:0.112-22.el7_7.1 will be updated
---> Package polkit.x86_64 0:0.112-26.el7 will be an update
---> Package postfix.x86_64 2:2.10.1-7.el7 will be updated
---> Package postfix.x86_64 2:2.10.1-9.el7 will be an update
---> Package rpcbind.x86_64 0:0.2.0-48.el7 will be updated
---> Package rpcbind.x86_64 0:0.2.0-49.el7 will be an update
---> Package samba-common.noarch 0:4.9.1-10.el7_7 will be updated
--> Processing Dependency: samba-common = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
--> Processing Dependency: samba-common = 4.9.1-10.el7_7 for package: samba-4.9.1-10.el7_7.x86_64
---> Package samba-common.noarch 0:4.10.4-11.el7_8 will be an update
---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7_7.6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-266.el7_8.1 will be an update
--> Finished Dependency Resolution
Error: Package: samba-4.9.1-10.el7_7.x86_64 (@updates)
Requires: samba-common = 4.9.1-10.el7_7
Removing: samba-common-4.9.1-10.el7_7.noarch (@updates)
samba-common = 4.9.1-10.el7_7
Updated By: samba-common-4.10.4-11.el7_8.noarch (updates)
samba-common = 4.10.4-11.el7_8
Available: samba-common-4.10.4-10.el7.noarch (base)
samba-common = 4.10.4-10.el7
You could try using --skip-broken to work around the problem
** Found 118 pre-existing rpmdb problem(s), 'yum check' output follows:
acl-2.2.51-15.el7.x86_64 is a duplicate with acl-2.2.51-14.el7.x86_64
bash-4.2.46-34.el7.x86_64 is a duplicate with bash-4.2.46-33.el7.x86_64
binutils-2.27-43.base.el7_8.1.x86_64 is a duplicate with binutils-2.27-41.base.el7_7.3.x86_64
centos-release-7-8.2003.0.el7.centos.x86_64 is a duplicate with centos-release-7-7.1908.0.el7.centos.x86_64
cloud-init-18.5-6.el7.centos.5.x86_64 is a duplicate with cloud-init-18.5-3.el7.centos.x86_64
curl-7.29.0-57.el7_8.1.x86_64 is a duplicate with curl-7.29.0-54.el7_7.2.x86_64
12:dhcp-libs-4.2.5-79.el7.centos.x86_64 is a duplicate with 12:dhcp-libs-4.2.5-77.el7.centos.x86_64
e2fsprogs-libs-1.42.9-17.el7.x86_64 is a duplicate with e2fsprogs-libs-1.42.9-16.el7.x86_64
elfutils-default-yama-scope-0.176-4.el7.noarch is a duplicate with elfutils-default-yama-scope-0.176-2.el7.noarch
expat-2.1.0-11.el7.x86_64 is a duplicate with expat-2.1.0-10.el7_3.x86_64
file-5.11-36.el7.x86_64 is a duplicate with file-5.11-35.el7.x86_64
file-libs-5.11-36.el7.x86_64 is a duplicate with file-libs-5.11-35.el7.x86_64
1:grub2-common-2.02-0.86.el7.centos.noarch is a duplicate with 1:grub2-common-2.02-0.80.el7.centos.noarch
1:grub2-pc-2.02-0.86.el7.centos.x86_64 has missing requires of grub2-tools = ('1', '2.02', '0.86.el7.centos')
1:grub2-tools-2.02-0.80.el7.centos.x86_64 has missing requires of grub2-tools-minimal = ('1', '2.02', '0.80.el7.centos')
1:grub2-tools-extra-2.02-0.86.el7.centos.x86_64 has missing requires of grub2-tools = ('1', '2.02', '0.86.el7.centos')
gssproxy-0.7.0-28.el7.x86_64 is a duplicate with gssproxy-0.7.0-26.el7.x86_64
hwdata-0.252-9.5.el7.x86_64 is a duplicate with hwdata-0.252-9.3.el7.x86_64
iwl100-firmware-39.31.5.1-76.el7.noarch is a duplicate with iwl100-firmware-39.31.5.1-72.el7.noarch
1:iwl1000-firmware-39.31.5.1-76.el7.noarch is a duplicate with 1:iwl1000-firmware-39.31.5.1-72.el7.noarch
iwl105-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl105-firmware-18.168.6.1-72.el7.noarch
iwl135-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl135-firmware-18.168.6.1-72.el7.noarch
iwl2000-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl2000-firmware-18.168.6.1-72.el7.noarch
iwl2030-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl2030-firmware-18.168.6.1-72.el7.noarch
iwl3160-firmware-25.30.13.0-76.el7.noarch is a duplicate with iwl3160-firmware-22.0.7.0-72.el7.noarch
iwl3945-firmware-15.32.2.9-76.el7.noarch is a duplicate with iwl3945-firmware-15.32.2.9-72.el7.noarch
iwl4965-firmware-228.61.2.24-76.el7.noarch is a duplicate with iwl4965-firmware-228.61.2.24-72.el7.noarch
iwl5000-firmware-8.83.5.1_1-76.el7.noarch is a duplicate with iwl5000-firmware-8.83.5.1_1-72.el7.noarch
iwl5150-firmware-8.24.2.2-76.el7.noarch is a duplicate with iwl5150-firmware-8.24.2.2-72.el7.noarch
iwl6000-firmware-9.221.4.1-76.el7.noarch is a duplicate with iwl6000-firmware-9.221.4.1-72.el7.noarch
iwl6000g2a-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl6000g2a-firmware-17.168.5.3-72.el7.noarch
iwl6000g2b-firmware-18.168.6.1-76.el7.noarch is a duplicate with iwl6000g2b-firmware-17.168.5.2-72.el7.noarch
iwl6050-firmware-41.28.5.1-76.el7.noarch is a duplicate with iwl6050-firmware-41.28.5.1-72.el7.noarch
iwl7260-firmware-25.30.13.0-76.el7.noarch is a duplicate with iwl7260-firmware-22.0.7.0-72.el7.noarch
kernel-headers-3.10.0-1127.19.1.el7.x86_64 is a duplicate with kernel-headers-3.10.0-1127.18.2.el7.x86_64
kernel-tools-libs-3.10.0-1127.19.1.el7.x86_64 is a duplicate with kernel-tools-libs-3.10.0-1062.18.1.el7.x86_64
kexec-tools-2.0.15-43.el7.x86_64 is a duplicate with kexec-tools-2.0.15-33.el7.x86_64
kmod-libs-20-28.el7.x86_64 is a duplicate with kmod-libs-20-25.el7_7.1.x86_64
libacl-2.2.51-15.el7.x86_64 is a duplicate with libacl-2.2.51-14.el7.x86_64
libcap-2.22-11.el7.x86_64 is a duplicate with libcap-2.22-10.el7.x86_64
libcom_err-1.42.9-17.el7.x86_64 is a duplicate with libcom_err-1.42.9-16.el7.x86_64
libcurl-7.29.0-57.el7_8.1.x86_64 is a duplicate with libcurl-7.29.0-54.el7_7.2.x86_64
libffi-3.0.13-19.el7.x86_64 is a duplicate with libffi-3.0.13-18.el7.x86_64
libseccomp-2.3.1-4.el7.x86_64 is a duplicate with libseccomp-2.3.1-3.el7.x86_64
libselinux-2.5-15.el7.x86_64 is a duplicate with libselinux-2.5-14.1.el7.x86_64
libselinux-utils-2.5-15.el7.x86_64 is a duplicate with libselinux-utils-2.5-14.1.el7.x86_64
libsmartcols-2.23.2-63.el7.x86_64 is a duplicate with libsmartcols-2.23.2-61.el7_7.1.x86_64
libsmbclient-4.10.4-11.el7_8.x86_64 has missing requires of samba-common = ('0', '4.10.4', '11.el7_8')
libss-1.42.9-17.el7.x86_64 is a duplicate with libss-1.42.9-16.el7.x86_64
libtalloc-2.1.16-1.el7.x86_64 is a duplicate with libtalloc-2.1.14-1.el7.x86_64
libtdb-1.3.18-1.el7.x86_64 is a duplicate with libtdb-1.3.16-1.el7.x86_64
libtevent-0.9.39-1.el7.x86_64 is a duplicate with libtevent-0.9.37-1.el7.x86_64
libuuid-2.23.2-63.el7.x86_64 is a duplicate with libuuid-2.23.2-61.el7_7.1.x86_64
libwbclient-4.9.1-10.el7_7.x86_64 has missing requires of libreplace-samba4.so(SAMBA_4.9.1)(64bit)
libwbclient-4.9.1-10.el7_7.x86_64 has missing requires of samba-client-libs = ('0', '4.9.1', '10.el7_7')
libwbclient-4.10.4-11.el7_8.x86_64 is a duplicate with libwbclient-4.9.1-10.el7_7.x86_64
linux-firmware-20191203-76.gite8a0f4c.el7.noarch is a duplicate with linux-firmware-20190429-72.gitddde598.el7.noarch
1:mariadb-libs-5.5.65-1.el7.x86_64 is a duplicate with 1:mariadb-libs-5.5.64-1.el7.x86_64
2:microcode_ctl-2.1-61.10.el7_8.x86_64 is a duplicate with 2:microcode_ctl-2.1-53.7.el7_7.x86_64
mongodb-org-4.2.9-1.el7.x86_64 has missing requires of mongodb-org-server = ('0', '4.2.9', None)
mongodb-org-tools-4.2.9-1.el7.x86_64 is a duplicate with mongodb-org-tools-4.2.5-1.el7.x86_64
numactl-libs-2.0.12-5.el7.x86_64 is a duplicate with numactl-libs-2.0.12-3.el7_7.1.x86_64
parted-3.1-32.el7.x86_64 is a duplicate with parted-3.1-31.el7.x86_64
4:perl-5.16.3-295.el7.x86_64 is a duplicate with 4:perl-5.16.3-294.el7_6.x86_64
1:perl-Pod-Escapes-1.04-295.el7.noarch is a duplicate with 1:perl-Pod-Escapes-1.04-294.el7_6.noarch
perl-Socket-2.010-5.el7.x86_64 is a duplicate with perl-Socket-2.010-4.el7.x86_64
4:perl-libs-5.16.3-295.el7.x86_64 is a duplicate with 4:perl-libs-5.16.3-294.el7_6.x86_64
4:perl-macros-5.16.3-295.el7.x86_64 is a duplicate with 4:perl-macros-5.16.3-294.el7_6.x86_64
procps-ng-3.3.10-27.el7.x86_64 is a duplicate with procps-ng-3.3.10-26.el7_7.1.x86_64
python-2.7.5-88.el7.x86_64 is a duplicate with python-2.7.5-86.el7.x86_64
python-libs-2.7.5-88.el7.x86_64 is a duplicate with python-libs-2.7.5-86.el7.x86_64
rsyslog-8.24.0-52.el7_8.2.x86_64 is a duplicate with rsyslog-8.24.0-41.el7_7.4.x86_64
samba-4.9.1-10.el7_7.x86_64 has missing requires of libCHARSET3-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libauth-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libcli-cldap-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libcli-nbt-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libcli-smb-common-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libcliauth-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libcmdline-contexts-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libdbwrap-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libgenrand-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libgse-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of liblibsmb-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libmessages-dgm-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libmsghdr-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libndr-samba-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libpopt-samba3-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libreplace-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsamba-cluster-support-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsamba-debug-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsamba-security-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsamba-sockets-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsamba3-util-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsecrets3-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libserver-id-db-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsmb-transport-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsmbd-base-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsmbd-shim-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsocket-blocking-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libsys-rw-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libutil-reg-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libutil-tdb-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of libxattr-tdb-samba4.so(SAMBA_4.9.1)(64bit)
samba-4.9.1-10.el7_7.x86_64 has missing requires of samba-client-libs = ('0', '4.9.1', '10.el7_7')
samba-4.9.1-10.el7_7.x86_64 has missing requires of samba-common-libs = ('0', '4.9.1', '10.el7_7')
samba-4.9.1-10.el7_7.x86_64 has missing requires of samba-common-tools = ('0', '4.9.1', '10.el7_7')
samba-4.9.1-10.el7_7.x86_64 has missing requires of samba-libs = ('0', '4.9.1', '10.el7_7')
samba-4.10.4-11.el7_8.x86_64 is a duplicate with samba-4.9.1-10.el7_7.x86_64
samba-4.10.4-11.el7_8.x86_64 has missing requires of samba-common = ('0', '4.10.4', '11.el7_8')
samba-client-4.10.4-11.el7_8.x86_64 has missing requires of samba-common = ('0', '4.10.4', '11.el7_8')
samba-client-libs-4.10.4-11.el7_8.x86_64 has missing requires of samba-common = ('0', '4.10.4', '11.el7_8')
samba-common-libs-4.10.4-11.el7_8.x86_64 has missing requires of samba-common = ('0', '4.10.4', '11.el7_8')
sed-4.2.2-6.el7.x86_64 is a duplicate with sed-4.2.2-5.el7.x86_64
selinux-policy-targeted-3.13.1-252.el7_7.6.noarch has missing requires of selinux-policy = ('0', '3.13.1', '252.el7_7.6')
shared-mime-info-1.8-5.el7.x86_64 is a duplicate with shared-mime-info-1.8-4.el7.x86_64
tuned-2.11.0-8.el7.noarch is a duplicate with tuned-2.11.0-5.el7_7.1.noarch
tzdata-2020a-1.el7.noarch is a duplicate with tzdata-2019c-1.el7.noarch
yum-cron-3.4.3-167.el7.centos.noarch is a duplicate with yum-cron-3.4.3-163.el7.centos.noarch

User avatar
TrevorH
Forum Moderator
Posts: 29493
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: cant open settings, update issue!?

Post by TrevorH » 2020/08/28 22:56:56

CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

quik
Posts: 2
Joined: 2020/08/28 20:52:26

Re: cant open settings, update issue!?

Post by quik » 2020/08/29 06:34:06

Hey thank you so much, this fixed my update issue and I have all updates/upgrades done: package-cleanup --cleandupes --removenewestdupes

But unfortunately still the same issue with opening settings, even after reboot...

Post Reply

Return to “CentOS 7 - Software Support”