update of packages won't work due to errors on some php packages

Issues related to applications and software problems
Post Reply
DrMartinus
Posts: 2
Joined: 2019/10/03 14:58:20

update of packages won't work due to errors on some php packages

Post by DrMartinus » 2020/08/01 14:17:05

Hi,

I'm running a remote server with CentOS 7.7.1908. I wasn't able to update it any further due to problems with some php packages. I had tried to upgrade PHP from the 5.x to 7.x version, and the upgrade process (I followed some instructions) worked fine, but afterwards I was still on PHP 5.x. So I didn't bother, but after a while noticed that the update didn't work. Here are the error messages at the end of the output of

Code: Select all

yum update
:

Code: Select all

Fehler: Paket: php-tidy-5.4.16-9.el7.x86_64 (@epel)
            Benötigt: php(zend-abi) = 20100525-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(zend-abi) = 20100525-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(zend-abi) = 20100525-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
Fehler: Paket: php-pecl-apcu-4.0.11-1.el7.x86_64 (@epel)
            Benötigt: php(zend-abi) = 20100525-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(zend-abi) = 20100525-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(zend-abi) = 20100525-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
Fehler: Paket: php-imap-5.4.16-9.el7.x86_64 (@epel)
            Benötigt: php(zend-abi) = 20100525-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(zend-abi) = 20100525-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(zend-abi) = 20100525-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(zend-abi) = 20170718-64
Fehler: Paket: php-imap-5.4.16-9.el7.x86_64 (@epel)
            Benötigt: php(api) = 20100412-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(api) = 20100412-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(api) = 20100412-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
Fehler: Paket: php-pecl-apcu-4.0.11-1.el7.x86_64 (@epel)
            Benötigt: php(api) = 20100412-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(api) = 20100412-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(api) = 20100412-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
Fehler: Paket: php-tidy-5.4.16-9.el7.x86_64 (@epel)
            Benötigt: php(api) = 20100412-64
            Entfernen: php-common-5.4.16-46.1.el7_7.x86_64 (@updates)
                php(api) = 20100412-64
            Aktualisiert durch: php-common-7.2.32-1.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
            Verfügbar: php-common-5.4.16-48.el7.x86_64 (base)
                php(api) = 20100412-64
            Verfügbar: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
                php(api) = 20170718-64
The German words mean: Fehler=Error; Benötigt=Needs; Entfernen=Remove; Aktualisiert durch=updated by; Verfügbar=Available
I am planning to upgrade the entire system to CentOS 8, but before that I need the packages properly set, and I would prefer to have CentOS 7.x be up to date for that next step.
Any suggestions on what to do?
Using CentOS 7.7 on a vserver.

User avatar
TrevorH
Forum Moderator
Posts: 29113
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: update of packages won't work due to errors on some php packages

Post by TrevorH » 2020/08/01 14:49:19

What is the output from rpm -qa \*php\* | sort
I am planning to upgrade the entire system to CentOS 8
There is NO upgrade. It's a reinstall. From scratch, back up everything, reinstall, restore, reconfigure.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”