foreman installtion

Issues related to applications and software problems
Post Reply
bala14880
Posts: 3
Joined: 2020/07/15 16:51:10

foreman installtion

Post by bala14880 » 2020/07/15 17:01:15

unable to install the foreman gives below error

foreman-installer
Execution of '/usr/bin/yum -d 0 -e 0 -y install foreman-postgresql' returned 1: Error: Package: tfm-rubygem-responders-2.3.0-1.el7.noarch (foreman)
Requires: rh-ruby22-ruby(release)
Package: tfm-rubygem-fog-core-1.42.0-1.el7.noarch (foreman)
Requires: rh-ruby22-rubygems
Package: 1:sclo-ror42-rubygem-activerecord-4.2.5.1-4.el7.noarch (centos-sclo-sclo)
Requires: rh-ruby22-ruby(rubygems)
Package: tfm-rubygem-ldap_fluff-0.4.4-1.el7.noarch (foreman)
Requires: rh-ruby22-ruby(release)
Package: sclo-ror42-rubygem-rack-test-0.6.3-3.el7.noarch (centos-sclo-sclo)
Requires: rh-ruby22-ruby(release)
Package: tfm-rubygem-pg-0.15.1-3.el7.x86_64 (foreman)
Requires: rh-ruby22-ruby(release)
Package: tfm-rubygem-net-ssh-3.0.2-2.el7.noarch (foreman)

server running with CentOS Linux release 7.8.2003 (Core)

User avatar
TrevorH
Forum Moderator
Posts: 29963
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: foreman installtion

Post by TrevorH » 2020/07/15 17:56:39

Did you install centos-release-scl first?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

bala14880
Posts: 3
Joined: 2020/07/15 16:51:10

Re: foreman installtion

Post by bala14880 » 2020/07/16 16:39:17

Hi TrevorH,

please find the below

updates | 2.9 kB 00:00:00
Package centos-release-scl-2-3.el7.centos.noarch already installed and latest version
Nothing to do

bala14880
Posts: 3
Joined: 2020/07/15 16:51:10

Re: foreman installtion

Post by bala14880 » 2020/07/16 16:48:42

[root@ibp-sde-autoval-puppet ~]# cat /etc/centos-release
CentOS Linux release 7.8.2003 (Core)
[root@ibp-sde-autoval-puppet ~]#

we should install foreman version1.14. Help me to resolve the issue.

User avatar
TrevorH
Forum Moderator
Posts: 29963
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: foreman installtion

Post by TrevorH » 2020/07/16 17:40:41

This is something you need to report to whoever provides those foreman packages. They are built to depend on SCL packages that are EOL and have been removed and are no longer available. The lowest ruby version in SCL now are rh-ruby23 though there are also 24 through 27 packages too.

According to https://access.redhat.com/support/polic ... hscl-rhel7 the ruby 22 packages were EOL more than 2 years ago.

PS, since I just read your demanding PM, it should be noted that everyone who inhabits this forum and replies regularly is a volunteer giving up their free time to help others. There is no support for CentOS other than from community members so please bear this in mind when asking for help - no-one is obligated to provide any answers. No-one here is paid by Red Hat to do this.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

maikcat
Posts: 7
Joined: 2019/01/11 13:01:58

Re: foreman installtion

Post by maikcat » 2020/07/17 09:25:05

foreman-1.24.3 works fine btw...

Michael.

Post Reply

Return to “CentOS 7 - Software Support”