Problem with repositories on CentOS 7 installed on Raspberry

Issues related to applications and software problems
Post Reply
Posts: 2
Joined: 2020/07/10 22:45:06

Problem with repositories on CentOS 7 installed on Raspberry

Post by Diedrich » 2020/07/11 20:48:16

I installed CentOS 7 on a Raspberry PI 3, managed to update yum once and trying to use it again throws the error shown below. I have tried several things, including rebuilding them with the information from the CentOS 7 repositories, but I have not managed to get it to work.

Part of the output of the hostnamectl command is:
Operating System: CentOS Linux 7 (AltArch)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 5.4.42-v7.1.el7
Architecture: arm

And the error when I try to update with yum is:

# yum update
Complementos cargados:fastestmirror
Determining fastest mirrors
Could not retrieve mirrorlist ... nfra=stock error was
14: curl#6 - "Could not resolve host:; Error desconocido"

One of the configured repositories failed (Desconocido),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=<repoid> ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable <repoid>
subscription-manager repos --disable=<repoid>

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice

yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/armhfp

My system is in Spanish. Does anyone know how I should configure the repositories to work properly? Which additional ones should I configure to install LAMP

Thanks in advance and greetings,

User avatar
Forum Moderator
Posts: 29985
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Problem with repositories on CentOS 7 installed on Raspberry

Post by TrevorH » 2020/07/11 22:22:06

Your problem is not with the repositories, it is with your DNS resolution. Can you ping ok? What is listed in /etc/resolv.conf for your DNS servers?
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 2
Joined: 2020/07/10 22:45:06

Re: Problem with repositories on CentOS 7 installed on Raspberry

Post by Diedrich » 2020/07/13 13:39:51

Hi TrevorH,

Thank you very much for your help, solved!!!, indeed I had the DNS wrongly configured.


Post Reply

Return to “CentOS 7 - Software Support”