Samba Install Failure

Issues related to applications and software problems
Post Reply
kbocek
Posts: 241
Joined: 2005/05/30 15:40:15
Location: Benicia CA, USA

Samba Install Failure

Post by kbocek » 2020/05/27 23:38:15

Upgrading a host from 7.7 to 7.8. I was getting errors regarding Samba so I uninstalled it and performed the upgrade. Now:

Code: Select all

$yum install samba
...
Error: Package: samba-client-libs-4.10.4-11.el7_8.x86_64 (updates)
           Requires: libtdb.so.1(TDB_1.3.17)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Does anyone have any idea?

tunk
Posts: 725
Joined: 2017/02/22 15:08:17

Re: Samba Install Failure

Post by tunk » 2020/05/28 10:02:29

I don't know what the problem is, but maybe this can shed some light:
rpm -qa|grep libtdb
rpm -ql libtdb
yum deplist samba-client-libs.x86_64
I guess you could also try to install it separately:
yum install libtdb

User avatar
TrevorH
Forum Moderator
Posts: 29112
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Samba Install Failure

Post by TrevorH » 2020/05/28 10:44:02

Looks like you've disabled your 'base' repo to me since yum provides 'libtdb.so.1(TDB_1.3.17)(64bit)' says it's provided by libtdb-1.3.18-1.el7.x86_64 in base.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

kbocek
Posts: 241
Joined: 2005/05/30 15:40:15
Location: Benicia CA, USA

Re: Samba Install Failure

Post by kbocek » 2020/05/29 14:12:09

Well after doing the upgrade there was a *second* set of upgrades that auto-installed. Samba then installed just fine. So the error was some version conflict between 7.7 and 7.8.

Samba has now installed just fine.

Thank you for your replies.

brilong
Posts: 2
Joined: 2018/04/16 20:50:10

Re: Samba Install Failure

Post by brilong » 2020/07/17 20:59:22

I believe this is still broken. Neither CentOS-7-x86_64-Everything-1908.iso nor CentOS-7-x86_64-Everything-2003.iso contain libtdb-1.3.17. I believe this RPM used to be in the updates repo, but since the updates repo was cleaned out when 2003 was released, libtdb-1.3.17 is nowhere to be found. If I change my base yum repo from 1908 to 2003 and sync updates, I have broken dependencies because libtdb-1.3.17 is missing.

Post Reply

Return to “CentOS 7 - Software Support”