Cant install minecraft

Issues related to applications and software problems
Post Reply
sd_iconoclast
Posts: 10
Joined: 2014/02/28 23:23:19

Cant install minecraft

Post by sd_iconoclast » 2020/05/13 05:28:56

I just tried to install minecraft using the minecraft.tar.gz file.
I extracted the tar file and executed "./minecraft-launcher".
Here is what I got:

[root@localhost minecraft-launcher]# ./minecraft-launcher
./minecraft-launcher: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./minecraft-launcher)
./minecraft-launcher: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./minecraft-launcher)
./minecraft-launcher: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./minecraft-launcher)

What is going wrong?

User avatar
TrevorH
Forum Moderator
Posts: 28514
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Cant install minecraft

Post by TrevorH » 2020/05/13 06:13:42

The program you are trying to run was not built to run on CentOS 7 and needs a newer version of glibc than we supply. You cannot run that copy on CentOS and you cannot update glibc on CentOS to a new enough version to make it work. You either need a different copy of the program, built to run with glibc 2.17 or a newer operating system. It would work on CentOS 8 which does have a new enough glibc.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”