mariadb service problem after 1127

Issues related to applications and software problems
User avatar
trevor14smith
Posts: 31
Joined: 2017/02/25 16:51:35
Contact:

mariadb service problem after 1127

Post by trevor14smith » 2020/04/29 12:22:02

I have a problem being unable to start the mariadb service - This was working prior to an upgrade to 3.10.0-1127
I am able to log onto mysql - the only thing I noticed was 2 blank users (which I deleted)
Any suggestions are appreciated!
1127mariadb.txt
(3.57 KiB) Downloaded 15 times

lightman47
Posts: 1161
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: mariadb service problem after 1127

Post by lightman47 » 2020/04/29 13:17:25

FWIW: All 4 of my 1127 updates required no less than TWO reboots before the machines began working properly again. I attributed that to seeing firmware installs go by as the update was progressing (but that's just me).
.
Remember - importing/building packages will likely "byte you in the butt" come update time, long after you'd forgotten you did that! Use repos whenever possible.

User avatar
jlehtone
Posts: 2934
Joined: 2007/12/11 08:17:33
Location: Finland

Re: mariadb service problem after 1127

Post by jlehtone » 2020/04/29 13:43:50

trevor14smith wrote:
2020/04/29 12:22:02
I have a problem being unable to start the mariadb service
7.7 had mariadb-5.5.64-1
7.8 has mariadb-5.5.65-1

Mariadb has a log file: /var/log/mariadb/mariadb.log
Does it tell why the start fails?

User avatar
trevor14smith
Posts: 31
Joined: 2017/02/25 16:51:35
Contact:

Re: mariadb service problem after 1127

Post by trevor14smith » 2020/04/29 15:35:24

I have mariadb 10.2.31
No log files in this location..

User avatar
jlehtone
Posts: 2934
Joined: 2007/12/11 08:17:33
Location: Finland

Re: mariadb service problem after 1127

Post by jlehtone » 2020/04/29 15:49:13

Where is it from?

Code: Select all

yum list installed \*mariadb\*

User avatar
trevor14smith
Posts: 31
Joined: 2017/02/25 16:51:35
Contact:

Re: mariadb service problem after 1127

Post by trevor14smith » 2020/04/29 16:03:34

Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: repo.miserver.it.umich.edu
* elrepo: linux-mirrors.fnal.gov
* epel: linux-mirrors.fnal.gov
* extras: mirrors.lug.mtu.edu
* nux-dextop: li.nux.ro
* updates: mirror.datto.com
835 packages excluded due to repository priority protections
Installed Packages
MariaDB-client.x86_64 10.2.31-1.el7.centos @mariadb
MariaDB-common.x86_64 10.2.31-1.el7.centos @mariadb
MariaDB-compat.x86_64 10.2.31-1.el7.centos @mariadb
MariaDB-server.x86_64 10.2.31-1.el7.centos @mariadb

User avatar
jlehtone
Posts: 2934
Joined: 2007/12/11 08:17:33
Location: Finland

Re: mariadb service problem after 1127

Post by jlehtone » 2020/04/29 16:24:08

Not familiar with that repo. Ok.

It would make sense to have at least an option for logging. Probably in the config. Can't see the config, obviously.

I did find that log file of mariadb-5.5.64-1 by looking at what the packages have. I would:

Code: Select all

rpm -qla MariaDB\* | grep -i log

User avatar
trevor14smith
Posts: 31
Joined: 2017/02/25 16:51:35
Contact:

Re: mariadb service problem after 1127

Post by trevor14smith » 2020/04/30 10:41:00

log file is located:
/var/lib/mysql/mysql-error.log
tail of that file:
1127 mariadb_tail_log.txt
(4.38 KiB) Downloaded 8 times

User avatar
TrevorH
Forum Moderator
Posts: 29136
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: mariadb service problem after 1127

Post by TrevorH » 2020/04/30 10:43:20

Do you have more than one mysqld running? Are the files it is complaining about in the right place? Is the filesystem mounted correctly with read/write access? Do you have any selinux denials in the output from aureport -a dated around the last time mariadb was started?
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
trevor14smith
Posts: 31
Joined: 2017/02/25 16:51:35
Contact:

Re: mariadb service problem after 1127

Post by trevor14smith » 2020/04/30 11:11:18

I guess now I am more confused!!
Look at the following sequence:
I thought mysql was mariadb were the same thing/process??

[root@localhost ~]# mysqladmin -u root -p status
Enter password:
Uptime: 67676 Threads: 8 Questions: 1 Slow queries: 0 Opens: 17 Flush tables: 1 Open tables: 11 Queries per second avg: 0.000
[root@localhost ~]# ^C
[root@localhost ~]# systemctl stop mariadb.service
[root@localhost ~]# mysqladmin -u root -p status
Enter password:
Uptime: 67959 Threads: 8 Questions: 2 Slow queries: 0 Opens: 17 Flush tables: 1 Open tables: 11 Queries per second avg: 0.000
[root@localhost ~]# systemctl stop mysql.service
[root@localhost ~]# mysqladmin -u root -p status
Enter password:
mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!

Post Reply

Return to “CentOS 7 - Software Support”