Centos 7 Network not working.

Issues related to applications and software problems
Post Reply
r3mus87
Posts: 1
Joined: 2020/02/22 17:58:48

Centos 7 Network not working.

Post by r3mus87 » 2020/02/22 18:15:14

Hello to all ,

Is first time when i came accros such a bizare problem. Ive installed centos 7 minimal, configured all 4 network ports with static IP . Then in order to install cpanel i need to disable NetworkManager and enable network.service to complete the job, however after reboot , i have no network what so ever until i run the comand ifdown if up on 1 of the ntwork cards then as a magic happen all start working.

To mention that 3 second before i get to the root loging page i get few pings then it go's off . I log in , then run the comand ifdown/up enp3s0f0 my first network card, then all starts getting ping. Just can figure out what is going on . Is like as if network.service goes on and off .

aks
Posts: 3008
Joined: 2014/09/20 11:22:14

Re: Centos 7 Network not working.

Post by aks » 2020/02/25 17:39:18

You've install cpanel, suggest asking cpanel for help....

confreak
Posts: 2
Joined: 2014/12/13 20:27:12

Re: Centos 7 Network not working.

Post by confreak » 2020/02/27 21:16:09

Can you post your server's startup logs?

I think that Network Manager has not been disabled properly. Check cPanel's how-to for network manager

As mentioned in the how-to:

1. Run the following commands
systemctl stop NetworkManager
systemctl disable NetworkManager

2. Adjust your network interface file (usually named ifcfg-eth0) at /etc/sysconfig/network-scripts/ifcfg-eth0 and append the following lines if they do not exist already:

NM_CONTROLLED=no
ONBOOT=yes

3. Run the following commands:
systemctl enable network.service
systemctl start network.service

But as mentioned above, the best place to ask about this is ask at cPanel's forums directly or consider a cpanel server management service

Post Reply

Return to “CentOS 7 - Software Support”