Page 1 of 1

[Solved] Loss of VLC in 7.7

Posted: 2019/09/14 18:58:43
by lightman47
Are there any other video players that will 'play anything' in Centos 7.7 as did VLC in previous versions?

Re: Loss of VLC in 7.7

Posted: 2019/09/14 23:11:59
by bonedome
you can install the latest (currently 3.0.8) from flathub
Personally I prefer mpv which has never failed to play anything.

Re: Loss of VLC in 7.7

Posted: 2019/09/16 14:05:20
by lightman47
OK - trying mpv (with SMplayer front end). It seems pretty good. However when I choose fullscreen there is no picture on my laptop, but the video is still playing fine. I can Maximize the screen and have it work, but it has the Titlebar and menu bars at the top, along with the task bar across the bottom. I suspect an Nvidia/bumblebee issue perhaps. This is semi-acceptable on the laptop.

I won't be converting my big video machine unless I can solve this though; it drives the big screen TV and also has an Nvidia card, but not bumblebee. I expect I'll just stop its 'automatic' updates and let it stay 7.6. Perhaps when CentOS 8 comes out ... I see there's a VLC for that.

Thank you.

Re: [Solved] Loss of VLC in 7.7

Posted: 2019/09/20 16:43:14
by lightman47
OK - 7.7 released and installed. With the exception of this one laptop (Nvidia/Bumblebee), mpv & smplayer are working beautifully on all the others. The laptop I can play with in the future, or just be happy with the title/task bars. The picture is beautiful!

I am a happy camper. The Nvidia video machine about which I worried was a matter of finding the HDMI audio output in Preferences.

Thank you, bonedome.

Re: [Solved] Loss of VLC in 7.7

Posted: 2019/09/20 16:56:17
by TrevorH
I do not think it possible for nux to rebuild a recent vlc on his repo without doing massive amounts of work to rebuild a whole raft of prereq packages that are required to do. I was able to use his vlc 2.2.5 spec file and the vlc 2.2.8 tarball and build that (with some hacking) but even 2.2.8 is old and has serious security problems.

The next alternative would be to switch everything to rpmfusion but since that repo doesn't play nicely with nux, that really means hoping that everything that I have and use from nux-dextop is also available from rpmfusion (which it isn't). Rpmfusion are current on vlc at 3.0.8 though. Just a lot of work and potentially a lack of things that do exist in nux but not in rpmfusion.

Third option: use flatpak .This is the one I'm currently using. Google for "org.videolan.VLC.flatpakref" and download the flatpakref file and then feed that into flatpak install /tmp/org.videolan.VLC.flatpakref and it'll install VLC for you as a flatpak. It seems to work as the default player and didn't need any adjustments of my system settings. It is a tiny bit greedy on disk space (1.2GB of prereqs for an 88MB vlc install) installing as a flatpak!

Code: Select all

[root@centos7 ~]# flatpak list
Ref                                                Options       
org.videolan.VLC/x86_64/stable                     system,current
org.freedesktop.Platform.html5-codecs/x86_64/18.08 system,runtime
org.kde.KStyle.Adwaita/x86_64/5.12                 system,runtime
org.kde.Platform/x86_64/5.12                       system,runtime

[root@centos7 ~]# flatpak info org.videolan.VLC/x86_64/stable
Ref: app/org.videolan.VLC/x86_64/stable
ID: org.videolan.VLC
Arch: x86_64
Branch: stable
Origin: flathub
Collection ID: org.flathub.Stable
Date: 2019-09-13 10:44:26 +0000
Subject: Remove /run/media (included in host) (63f9ea4c)
Commit: 10f379499e07b2105747cf3f1d2c67ca58f7d4e28f4e81319f0a0374f620b984
Parent: 8db2c20401cc62ccd9ecc25fd9a5859b6080d67c639a8d5a5ee43a83ec936e96
Location: /var/lib/flatpak/app/org.videolan.VLC/x86_64/stable/10f379499e07b2105747cf3f1d2c67ca58f7d4e28f4e81319f0a0374f620b984
Installed size: 78.3 MB
Runtime: org.kde.Platform/x86_64/5.12
Sdk: org.kde.Sdk/x86_64/5.12

[root@centos7 ~]# flatpak info org.freedesktop.Platform.html5-codecs/x86_64/18.08
Ref: runtime/org.freedesktop.Platform.html5-codecs/x86_64/18.08
ID: org.freedesktop.Platform.html5-codecs
Arch: x86_64
Branch: 18.08
Origin: flathub
Collection ID: org.flathub.Stable
Date: 2019-09-05 14:59:43 +0000
Subject: Export org.freedesktop.Platform.html5-codecs
Commit: 6ebb408b6e2571dde89612393fd59c99489ddfdb8f603a9b2603b73be9ab0550
Parent: 91acb59302e9c495c6878dc1987fd50a38edabc89f8150b9bce06fe2ba14d1fd
Location: /var/lib/flatpak/runtime/org.freedesktop.Platform.html5-codecs/x86_64/18.08/6ebb408b6e2571dde89612393fd59c99489ddfdb8f603a9b2603b73be9ab0550
Installed size: 8.8 MB

[root@centos7 ~]# flatpak info org.kde.KStyle.Adwaita/x86_64/5.12
Ref: runtime/org.kde.KStyle.Adwaita/x86_64/5.12
ID: org.kde.KStyle.Adwaita
Arch: x86_64
Branch: 5.12
Origin: flathub
Collection ID: org.flathub.Stable
Date: 2019-09-02 08:02:40 +0000
Subject: Backport upstream fixes (825e2347)
Commit: 4b28aaee7c7500b7d21419ba3cbc6f114ca4a7a5b9056d0ac41b36231c332f97
Parent: 2cd089684e6ecb427da5daf1e24297fbda49591295b0af65c1e97dd4423d8069
Location: /var/lib/flatpak/runtime/org.kde.KStyle.Adwaita/x86_64/5.12/4b28aaee7c7500b7d21419ba3cbc6f114ca4a7a5b9056d0ac41b36231c332f97
Installed size: 16.3 MB
[root@centos7 ~]# flatpak info org.kde.Platform/x86_64/5.12
Ref: runtime/org.kde.Platform/x86_64/5.12
ID: org.kde.Platform
Arch: x86_64
Branch: 5.12
Origin: flathub
Collection ID: org.flathub.Stable
Date: 2019-09-16 18:45:32 +0000
Subject: Fix build of kwayland-integration (e5349082)
Commit: 5539ccd35690b5774e46e8d34fb576b0f86331c59cb8ee7a4ea31b38ccde5886
Parent: 99d0d003f979f69c4b1db6f588c2457808a58412e707498dfd889d0683858c1e
Location: /var/lib/flatpak/runtime/org.kde.Platform/x86_64/5.12/5539ccd35690b5774e46e8d34fb576b0f86331c59cb8ee7a4ea31b38ccde5886
Installed size: 1.2 GB
[root@centos7 ~]# 

Re: [Solved] Loss of VLC in 7.7

Posted: 2019/09/20 17:34:36
by lightman47
Heh. I'd given up on VLC, at least for now, after reading comments (somewhere after I'd visited by a poster 'similarly named' regarding compilation problems with 2.2 and 3. It was then that I posted this 'Loss of VLC' post.

I am currently happy with mpv/smplayer - it seems to work on all my machines - Nvidia or not. My 'toolbox' Dell G3 hybrid video is the only (VERY minor) setback. While entirely watch-able/enjoyable, I suspect smplayer/mpv "full screen" switches drivers when it shouldn't, or doesn't switch when it should. In either case, it's not a big deal.

Thanks so much!

Re: [Solved] Loss of VLC in 7.7

Posted: 2019/09/20 19:25:35
by bonedome
if you play a video from the command line, mpv will tell you what video output is being used.
The default is opengl, you can try hardware accel by installing the driver for your cpu, vaapi or vdpau, and trying with

Code: Select all

mpv --vo=vdpau ~/videos/VC-1_23.976_sample.mkv
to show all your options

Code: Select all

mpv --list-options
although mpv docs stated in the past, something along the lines of "HW acceleration doesn't work well on linux" hence opengl software rendering as default.
Note HWaccel only works with h264 video

On my dell laptop 1600x900 screen, 1080p videos played with mpv always seem to use less cpu than other players and vlc is equally unhappy with HWaccel

Re: [Solved] Loss of VLC in 7.7

Posted: 2019/09/20 20:31:03
by lightman47
Having 'been here before', I knew where to go in smplayer to specify the correct audio. Thanks.