Xvnc killed by SIGABRT, started happening after yum update

Issues related to applications and software problems
Post Reply
Posts: 2
Joined: 2019/01/17 23:46:04

Xvnc killed by SIGABRT, started happening after yum update

Post by sam.clark » 2019/01/18 00:07:19

I have been using Xvnc (from the tigervnc package) for about a year to remote login to computers and access a full CentOS 7 MATE desktop. It was working well until I ran yum update on December 10, 2018. After this update (which included many packages, since I had not updated in some time), the Xvnc server crashes whenever I open and then close two specific GUI applications: GMV and Xmgr. These applications are specialty programs that most people probably don't run, but I use them for work to post-process CFD results. They are both Motif applications written long ago, and I suspect that perhaps their reliance on Motif is related to the problem.

When I close the GUI window of either Xmgr or GMV, the Xvnc server immediately crashes, and I cannot reconnect to it unless I SSH into the machine, become root, and restart the Xvnc service using:

Code: Select all

service vncserver@:1.service restart
When I become root, the system outputs a message like this (the numeric ID at the end changes):

Code: Select all

ABRT has detected 1 problem(s). For more info run: abrt-cli list --since 1547765235
And when I run the suggested abrt-cli command, I get this:

Code: Select all

# abrt-cli list --since 1547765235
id f0c3a4d4f83229b5aaa5120a5e03b9847a088ca6
reason:         Xvnc killed by SIGABRT
time:           Wed 12 Dec 2018 02:32:58 PM MST
cmdline:        /usr/bin/Xvnc :1 -auth /home/lobo/.Xauthority -desktop 'kelvin:1 (lobo)' -fp catalogue:/etc/X11/fontpath.d -geometry 1920x1080 -pn -rfbauth /home/lobo/.vnc/passwd -rfbport 5901 -rfbwait 30000
package:        tigervnc-server-minimal-1.8.0-13.el7
uid:            511 (lobo)
count:          7
Directory:      /var/spool/abrt/ccpp-2018-12-12-14:32:58-6901
I tried the following things to resolve the problem:

1. I tried rolling back the "yum update" that caused the problem. Unfortunately it did not work because it said the older versions of the packages were no longer available in the repos.

2. I searched Google but I wasn't able to find much. This thread on the RedHat forums looked like maybe a similar issue: https://bugzilla.redhat.com/show_bug.cgi?id=1660513 (However, I am not running my programs as root, and they are in Motif, not Tcl.)

3. I waited about a month and then ran "yum update" again in the hope that maybe some package would magically fix the issue. Sadly, only a few packages were updated and the problem is still present.

Has anyone else experienced this kind of crash with Xvnc recently after running "yum update"? If so, do you know of a solution? Thanks for any help you can provide, and please let me know if more information would be useful in diagnosing or troubleshooting the problem.
Sam Clark

Posts: 1
Joined: 2019/05/17 10:23:26

Re: Xvnc killed by SIGABRT, started happening after yum update

Post by vsokov » 2019/05/17 10:34:47

Hello Sam!
You need:

1) Download xorg-x11-server-....src.rpm source codes from official repository (my path is tested for version 1.19.5 and 1.20.1);
Better way is to download src.rpm package (with some version as installed on Your system) from your OS repository.
2) Install it to ~/rpmbuild directory with rpm -i <source package>;
3) Copy path file into ~/rpmbuild/SOURCES directory;
4) Insert path to ~/rpmbuild/SPECS/xorg-x11-server.spec file (look for Patch.... strings and add something like
Patch10000: xorg_xfreerdp_fullscreen_crash_fix.patch after other PatchNNNN strings).
5) Go to SPEC directory and build rpm with rpmbuild -bb xorg-x11-server.spec;
6) Go to RPMS directory and install resulting xorg-x11-server-Xorg-....rpm file with command like
sudo rpm -ui --force <rpm file name>.

Look patch file at addition.
With best regards,
Vasiliy Sokov
(1.51 KiB) Downloaded 58 times

Posts: 2
Joined: 2019/01/17 23:46:04

Re: Xvnc killed by SIGABRT, started happening after yum update

Post by sam.clark » 2019/05/22 20:25:40

@vsokov, thank you very much for your instructions. I've never built an RPM from source before, and your instructions were very helpful. I was able to successfully build the patched RPM files for my system. Unfortunately, the X server is still crashing when I close the MOTIF application that's causing problems. So perhaps your patch fixed a different crash cause, but not the one I'm hitting. At this point, I'm tempted to give up on CentOS 7 (for this bug and also a few other annoyances) and just revert back to CentOS 6. Thanks again for your help, it is much appreciated.
Sam Clark

Post Reply

Return to “CentOS 7 - Software Support”