qpid-cpp-client will not install

Issues related to applications and software problems
Post Reply
captjohn71
Posts: 4
Joined: 2018/08/21 02:52:11

qpid-cpp-client will not install

Post by captjohn71 » 2018/08/21 03:08:02

I am trying to install qpid-cpp-client on my Centos 7.5 machine but get a dependency error which i have been unable to resolve. The yum output is attached to this post. any help in resolving this would be appreciated.

[Moderator edit: removed attachment and put the text in the post]
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: repos.lax.quadranet.com
* epel: mirror.prgmr.com
* extras: mirror.hmc.edu
* updates: centos.sonn.com
166 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package qpid-cpp-client.x86_64 0:1.38.0-2.el7 will be installed
--> Processing Dependency: qpid-proton-c(x86-64) >= 0.24.0 for package: qpid-cpp-client-1.38.0-2.el7.x86_64
--> Processing Dependency: libqpid-proton-core.so.10()(64bit) for package: qpid-cpp-client-1.38.0-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: qpid-cpp-client-1.38.0-2.el7.x86_64 (epel)
Requires: libqpid-proton-core.so.10()(64bit)
Error: Package: qpid-cpp-client-1.38.0-2.el7.x86_64 (epel)
Requires: qpid-proton-c(x86-64) >= 0.24.0
Installed: qpid-proton-c-0.14.0-2.el7.x86_64 (@extras)
qpid-proton-c(x86-64) = 0.14.0-2.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 29490
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: qpid-cpp-client will not install

Post by TrevorH » 2018/08/21 08:56:19

You have qpid-proton-c 0.14 installed from the CentOS extras repo. You're trying to install a package from EPEL that requires a newer version of that qpid-proton-c package that is also in EPEL. I suspect that you have configured yum-plugin-priorities to prefer extras over EPEL so it will not find the newer copy that is in EPEL (because you told it not to).

You either need to adjust your priorities to make EPEL more important (probably not the best solution) or you need to add exclude=qpid-proton-c (or perhaps better since there are other qpid packages in extras, use exclude=qpid*) to the /etc/yum.repos.d/CentOS-Base.repo in the [extras] section.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

captjohn71
Posts: 4
Joined: 2018/08/21 02:52:11

Re: qpid-cpp-client will not install

Post by captjohn71 » 2018/08/22 13:39:03

Thank you very much adding the exclude line solved the problem.

Post Reply

Return to “CentOS 7 - Software Support”