Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Issues related to applications and software problems
User avatar
psposito
Posts: 16
Joined: 2014/12/27 22:27:25
Contact:

Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by psposito » 2017/10/30 20:25:26

The latest Skype (ver 8.9) on my CentOs 7 Desktop/Workstation machines cannot be installed/updated....

When updating, I get the following:

error: Failed dependencies:
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) is needed by skypeforlinux-8.9.0.1-1.x86_64

Any suggestions?

User avatar
TrevorH
Forum Moderator
Posts: 30872
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by TrevorH » 2017/10/30 22:05:19

Report it to Microsoft/Skype. They built it against a newer glibc than we ship and it cannot be used.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
psposito
Posts: 16
Joined: 2014/12/27 22:27:25
Contact:

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by psposito » 2017/10/30 22:15:39

Already did! I hope they will response... I am not the only one..

https://answers.microsoft.com/en-us/sky ... 266d235689

But what about, if they do not do any further steps?

mghe
Posts: 766
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by mghe » 2017/10/30 23:04:55

psposito wrote:
But what about, if they do not do any further steps?
Old version still works very well or just change to other communicator.

User avatar
psposito
Posts: 16
Joined: 2014/12/27 22:27:25
Contact:

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by psposito » 2017/10/30 23:12:23

It is not easy to switch... Skype is very famous versus Jitsi or others.... All of my contacts use Skype...

User avatar
TrevorH
Forum Moderator
Posts: 30872
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by TrevorH » 2017/10/31 00:09:05

The old one is still in their repo so you could just install it by full version number - yum install skypeforlinux-5.5.0.1-1
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
psposito
Posts: 16
Joined: 2014/12/27 22:27:25
Contact:

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by psposito » 2017/10/31 05:18:55

Now I am using skypeforlinux-5.5.0.1-1 but I am not aware for how long it will operate without the need for update...

User avatar
TrevorH
Forum Moderator
Posts: 30872
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by TrevorH » 2017/10/31 07:35:16

They usually announce well in advance when an older one will stop. For 4.x they gave at least 3 months notice.
CentOS 6 died in November 2020 - migrate to a new version!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
psposito
Posts: 16
Joined: 2014/12/27 22:27:25
Contact:

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by psposito » 2017/10/31 20:19:38

Thank you for the answer.

Up to now, their answer is that they will not build it for CentOs and RHEL....

https://answers.microsoft.com/en-us/sky ... 266d235689

"What's the point in first releasing Skype Beta built against an older version of glibc, for RHEL/CentOS users to use/test, only to
use the unsupported version to build the stable release against?
Hell, now even Google does this with Chrome for CentOS 7 anymore..."
Milos Blazevic 31/10/2017....

So what can be done when the current (Beta) version will expire?

indikaaruna
Posts: 3
Joined: 2017/11/01 11:25:49

Re: Latest Skype 8.9.0.1-1.x86_64 cannot be installed Centos 7.4...

Post by indikaaruna » 2017/11/02 07:51:43

psposito wrote:Thank you for the answer.

Up to now, their answer is that they will not build it for CentOs and RHEL....

https://answers.microsoft.com/en-us/sky ... 266d235689

"What's the point in first releasing Skype Beta built against an older version of glibc, for RHEL/CentOS users to use/test, only to
use the unsupported version to build the stable release against?
Hell, now even Google does this with Chrome for CentOS 7 anymore..."
Milos Blazevic 31/10/2017....

So what can be done when the current (Beta) version will expire?
Still issue is not fixed? Do you have good news from microsoft ?

Post Reply

Return to “CentOS 7 - Software Support”