Page 1 of 1

Error while compiling squid

Posted: 2016/05/10 12:35:58
by Kunwar
I am trying to compile squid 3.5.19 with the following options:

Code: Select all


	--prefix=/usr \
	--exec-prefix=/usr \
        --includedir=/usr/include \
        --datadir=/usr/share \
	--bindir=/usr/sbin \
        --libdir=/usr/lib64 \
        --libexecdir=/usr/lib64/squid \
        --localstatedir=/var \
        --sysconfdir=/etc/squid \
        --sharedstatedir=/var/lib \
        --with-logdir=/var/log/squid \
        --with-pidfile=/var/run/squid.pid \
        --with-default-user=squid \
        --enable-silent-rules \
        --enable-dependency-tracking \
        --with-openssl \
        --enable-icmp \
        --enable-delay-pools \
        --enable-useragent-log \
        --enable-esi \
        --enable-follow-x-forwarded-for \
        --enable-ipf-transparent \
        --enable-auth \

but I am getting this error while compiling:
configure: error: unable to make IPFilter work with netinet/ headers centos

All my research suggests me that the error is related to the following option:

Code: Select all

       --enable-ipf-transparent \
so my question is how should I fix this issue? or should I just omit --enable-ipf-transparent .... I plan to use quid for SSL buming in transparent mode.

Re: Error while compiling squid

Posted: 2016/05/13 13:40:36
by aks
Never tried it, but this post may help:
https://www.smoothnet.org/squid-v3-5-pr ... -ssl-bump/

Re: Error while compiling squid

Posted: 2016/05/16 10:44:55
by yarns
I'm getting same error. Did you solved your problem?

Re: Error while compiling squid

Posted: 2016/05/18 18:14:50
by Kunwar
Yes I was able to resolve the issue.... I figured out that the proxy works just fine without this flag.I was able to configure transparent proxy with ssl bumping... Feel free to ask if you come across any issue.