CentOS 7 Skype

Issues related to applications and software problems
Post Reply
TJDCD
Posts: 7
Joined: 2014/12/27 17:26:14

CentOS 7 Skype

Post by TJDCD » 2014/12/27 19:45:12

Hi guys,

Trying to install skype but this don't seem to work anymore:

viewtopic.php?f=47&t=48066

Error: Package: skype-4.3.0.37-2.R.i586 (nux-dextop)
Requires: libQtWebKit.so.4

qtwebkit.i686 is not available even with epel and nux, manually trying to install it requires another bunch of dependecies that are not available.

Do you guys have any other way to do it?

Thanks

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: CentOS 7 Skype

Post by gerald_clark » 2014/12/27 21:17:20

If you are going to use nux-dextop, you also need to install and enable epel. It contains the necessary dependency.
yum install epel-release

User avatar
TrevorH
Forum Moderator
Posts: 29171
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 Skype

Post by TrevorH » 2014/12/28 14:16:19

Apparently you didn't enable EPEL for the install...

Code: Select all

[root@centos7 /]# yum provides '*/libQtWebKit.so.4'
Loaded plugins: changelog, langpacks, priorities, versionlock
qtwebkit-2.3.3-3.el7.i686 : Qt WebKit bindings
Repo        : nux-dextop
Matched from:
Filename    : /usr/lib/libQtWebKit.so.4
Filename    : /usr/lib/sse2/libQtWebKit.so.4
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

TJDCD
Posts: 7
Joined: 2014/12/27 17:26:14

Re: CentOS 7 Skype

Post by TJDCD » 2014/12/28 17:10:40

I have both epel and nux enabled:

The problem was that I have Yum Priorities enabled:

255 packages excluded due to repository priority protections
nux-dextop/x86_64/filelists_db | 2.0 MB 00:01
qtwebkit-2.3.3-3.el7.x86_64 : Qt WebKit bindings
Repo : epel
Matched from:
Filename : /usr/lib64/libQtWebKit.so.4

When TrevorH placed his output I realize that probably that was the issue, after placing the epel and nux with the same priority as the Base:

Installed:
skype.i586 0:4.3.0.37-2.R

Thanks for your comments, they helped to close this one. :)

TJDCD
Posts: 7
Joined: 2014/12/27 17:26:14

Re: CentOS 7 Skype

Post by TJDCD » 2014/12/28 20:51:15

Just to add that for proper theme config on skype (at least on a minimal setup like mine - Openbox) I had the need to:

yum install alsa-lib.i686 libXv.i686 libXScrnSaver.i686 libcanberra.i686 libcanberra-gtk2.i686

and for sound to work properly (apulse workaround on Arch not available in CentOS) I had the need to:

yum install alsa-plugins-pulseaudio.i686

PS: When installing skype from Nux it doesn't push any of the packages above.

Post Reply

Return to “CentOS 7 - Software Support”