Installing Python-2.6.9 from source fails

Issues related to applications and software problems
Post Reply
mmulqu
Posts: 11
Joined: 2013/02/05 16:09:31

Installing Python-2.6.9 from source fails

Post by mmulqu » 2014/11/22 16:58:37

My developers need Python-2.6.9 installed on one of our machines running CentOS 7. I'd like to avoid using a docker container but will do that if it comes to it. I'm using a build directory and running

Code: Select all

../Python-2.6.9/configure --prefix=/usr/local --enable-unicode=ucs4 --enable-shared LDFLAGS="-Wl,-rpath /usr/local/lib"
Configure goes well and then I run

Code: Select all

make -j16
This is where I have a problem. I get these errors.

Code: Select all

Failed to find the necessary bits to build these modules:
_bsddb             bsddb185           dl              
imageop            linuxaudiodev      ossaudiodev     
sunaudiodev                                           
To find the necessary bits, look in setup.py in detect_modules() for the module's name.


Failed to build these modules:
dbm
The full output from make is at http://pastebin.com/raw.php?i=D1PLiLzz. Does anyone know how to fix this? Maybe I'd be better served by pushing back on my developers to use docker. Advice is much appreciated.

Thanks,

Matt

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Installing Python-2.6.9 from source fails

Post by gerald_clark » 2014/11/22 17:28:24

Perhaps you could use CentOS 6. It uses python 2.6.6.

mmulqu
Posts: 11
Joined: 2013/02/05 16:09:31

Re: Installing Python-2.6.9 from source fails

Post by mmulqu » 2014/11/22 17:38:12

They need gcc-4.8 and both python-2.6 and python-2.7. I chose CentOS 7 because, during the planning stages, I was told that they would only need gcc-4.8 and python-2.7. Now that they've been using this machine for a few days they're saying they need all three. Thanks for the suggestion but I should have provided this information with the initial post.

chemal
Posts: 682
Joined: 2013/12/08 19:44:49

Re: Installing Python-2.6.9 from source fails

Post by chemal » 2014/11/23 04:41:46

mmulqu wrote:They need ... both python-2.6 and python-2.7.
Tell them to fix their code?

Post Reply

Return to “CentOS 7 - Software Support”