Page 1 of 1

VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/21 15:32:49
by maddyir
I have installed "nux desktop" for multimedia setup on CentOS7. I am following http://wiki.centos.org/TipsAndTricks/Mu ... aOnCentOS7. While I use "yum install vlc", the installation gets halted with "KeyboardInterrupt".

Code: Select all

# yum  install vlc
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.dhakacom.com
 * epel: mirrors.yun-idc.com
 * extras: mirror.dhakacom.com
 * nux-dextop: mirror.li.nux.ro
 * updates: mirror.dhakacom.com
Traceback (most recent call last):==-           ] 227 kB/s | 4.1 MB   00:45 ETA 
  File "/usr/libexec/urlgrabber-ext-down", line 75, in <module>
    main()
  File "/usr/libexec/urlgrabber-ext-down", line 61, in main
    fo = PyCurlFileObject(opts.url, opts.filename, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1258, in __init__
    self._do_open()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1589, in _do_open
    self._do_grab()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1723, in _do_grab
    self._do_perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1517, in _do_perform
    raise KeyboardInterrupt
KeyboardInterrupt

Exiting on user cancel
Also while installing flash plugin.

Code: Select all

# yum install flash-plugin
Loaded plugins: fastestmirror, langpacks
adobe-linux-x86_64                                                                                 |  951 B  00:00:00     
adobe-linux-x86_64/primary                                                                         | 1.2 kB  00:00:06     
Loading mirror speeds from cached hostfile
 * base: mirror.dhakacom.com
 * epel: mirrors.yun-idc.com
 * extras: mirror.dhakacom.com
 * nux-dextop: mirror.li.nux.ro
 * updates: mirror.dhakacom.com
Traceback (most recent call last):             19% [======-                             ]  43 kB/s | 925 kB  00:01:30 ETA 
  File "/usr/libexec/urlgrabber-ext-down", line 75, in <module>
    main()
  File "/usr/libexec/urlgrabber-ext-down", line 61, in main
    fo = PyCurlFileObject(opts.url, opts.filename, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1258, in __init__
    self._do_open()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1589, in _do_open
    self._do_grab()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1723, in _do_grab
    self._do_perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1517, in _do_perform
    raise KeyboardInterrupt
KeyboardInterrupt


Exiting on user cancel
Same problem occurs while installing java also. Please help

Re: VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/21 15:55:22
by gerald_clark
Sounds very similar to a VM problem posted earlier.

Re: VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/21 21:05:16
by TrevorH
The keyboard interrupt is a bug in yum. Temporary solution posted viewtopic.php?f=47&t=47372&start=10#p205722

Re: VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/24 02:49:51
by maddyir
I edited /usr/lib/python2.7/site-packages/urlgrabber/grabber.py elif errcode in (42, 55, 56): to elif errcode == 42:
Now I get this error.

Code: Select all

 # yum list *vlc*
Traceback (most recent call last):
  File "/usr/bin/yum", line 4, in <module>
    import yum
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 59, in <module>
    import config
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 30, in <module>
    from parser import ConfigPreProcessor, varReplace
  File "/usr/lib/python2.7/site-packages/yum/parser.py", line 4, in <module>
    import urlgrabber
  File "/usr/lib/python2.7/site-packages/urlgrabber/__init__.py", line 55, in <module>
    from grabber import urlgrab, urlopen, urlread
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1509
    elif errcode == 42:
       ^
SyntaxError: invalid syntax
I get the same error while using

Code: Select all

# yum  install vlc

Code: Select all

# yum clean all[

Code: Select all

# yum upgrade

Re: VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/24 03:31:24
by maddyir
I am getting this Notification Pop-up. Image attached.
screenshot notif.png
screenshot notif.png (23.83 KiB) Viewed 1454 times
I am also getting this while trying to "su".

Code: Select all

$ su
Password: 
ABRT has detected 2 problem(s). For more info run: abrt-cli list --since 1416799130
[root@xxxxxx]# abrt-cli list --since 1416799130
id 4e913859f7e4d08f9ae17bc22b410952a139688f
Directory:      /var/tmp/abrt/Python-2014-11-24-08:57:57-5800
count:          1
executable:     /usr/bin/yum
package:        yum-3.4.3-118.el7.centos
time:           Monday 24 November 2014 08:57:57 AM IST
uid:            0

:?:

Re: VLC, Flash etc not getting installed "KeyboardInterrupt"

Posted: 2014/11/24 08:18:56
by TrevorH
You apparently made some non-obvious syntax error in your change since it works perfectly here and the complaint is about the very line you changed.