Gscan2pdf

Issues related to applications and software problems
Post Reply
mfsmoura
Posts: 1
Joined: 2014/11/11 08:50:02

Gscan2pdf

Post by mfsmoura » 2014/11/11 09:22:16

Hi. Until last week I was a unconditional fan of Ubuntu but, after trying CentOS 7 in my laptop (Gnome interface), I became very interested on this distribution version. The majority of the software that I use is functioning well except Gscan2pdf. I already activated epel repository but I still cant´n install it via yum. I think that in CentOS version 6 gscan2pdf has no problems. After trying a local install (gscan2pdf-1.2.6-1.noarch.rpm) in my 64 bit system the errors that I get are:
--> Finished Dependency Resolution
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Sane)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(:MODULE_COMPAT_5.18.2)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Gtk2::Ex::PodViewer)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Goo::Canvas)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: gocr
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Sane) >= 0.05
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Gtk2::Ex::Simple::List)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Gtk2::ImageView)
Error: Package: gscan2pdf-1.2.6-1.noarch (/gscan2pdf-1.2.6-1.noarch)
Requires: perl(Set::IntSpan) >= 1.10
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Thank you for your attention.

User avatar
TrevorH
Forum Moderator
Posts: 29112
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Gscan2pdf

Post by TrevorH » 2014/11/11 09:58:59

You can't just take a random rpm that was built for a different distro and install it on CentOS 7. That shows it wants perl 5.18 and CentOS 7 has 5.16 so it will not work. If you want to use this then you will need to get the SRPM for that and rebuild it on your system to produce a binary rpm that you can install.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
Info for USB installs on http://wiki.centos.org/HowTos/InstallFromUSBkey
CentOS 5 is dead, do not use it.
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”