Page 1 of 1

no yum repositories in minimal-installation

Posted: 2014/11/06 17:31:16
by adust

my Problem is, that there's no repository in my minimal-installation and i can't find out how to put in the standard-repo.
I tried epel and ius, but i can't find many packages like boost-devel gcc-c++ mysql-devel,...
I hoped it would just work (yes, I'm a noob, but i'm trying to become better).

When I look which repos are enabled: (translated)

Code: Select all

# yum repolist all
loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
repolist: 0
I looked up my /etc/yum.repos.d/ and it's just empty.
Re-installing the System doesn't seem to make any difference.
I know that I can add repos with "rpm -Uvh" but I just can't find out the path(s?) of the standard-repos.

Hope someone can tell me how to find those urls. I can't find them in the wiki, too. ... ositories/


Re: no yum repositories in minimal-installation

Posted: 2014/11/06 18:22:58
by avij
How did you install CentOS? Which disk image? Did you use the official CentOS .iso images or something that your ISP has provided? All CentOS installations should have the appropriate repo definition files in /etc/yum/repos.d by default.

Re: no yum repositories in minimal-installation

Posted: 2014/11/07 09:02:10
by adust
Thanks for the quick answer.

I used the iso from ... os/x86_64/
It is linked from this site: so it should be an official.
It's a network-install, as installation source i used

When I was asked wich packages I'd like to install, I took "minimal installation", but there's no repositories i could get my packages from.
I don't think that it's correct that even the repos have to be installed manually, but even though - I can't find out the URL.

Re: no yum repositories in minimal-installation

Posted: 2014/11/07 10:36:22
by avij
This is odd. I just made a minimal installation (netinstall) as a test, and the centos-release package got installed. The repository config files are included in that package.

Please make sure you have the centos-release package installed by running rpm -q centos-release. If it shows that it is installed, run rpm -V centos-release to see what rpm thinks about the installed repo files.

If you do not have centos-release installed, the following should get it installed:

Code: Select all

yum install
You can also try 'reinstall' instead of 'install' to restore the repo files, if they have been deleted for some reason after the install of centos-release.

Re: no yum repositories in minimal-installation

Posted: 2014/11/07 19:17:53
by adust
With rpm -q centos-release it tells me centos-release-7-0.e17.0.140617.3.x86_64
rpm -V centos-release does nothing visible.
When I look for repolist it's still filled with epel, ius and remi but no new/standard repos.

After that I tried to reinstall the repo with

Code: Select all

yum reinstall

but that didn't work either.

I tried installing it again and this time it worked.
I looked for my mistake and found this:
On my first try I got to this page: ... ase-07.png
I think I overread the "pre-release" both times and took as my installation source.
Because of the "-latest" I thought it would be the actual version of CentOS and so the ratrace began..
Now all the repos are where they should be.

I'm very sorry but maybe someone has made the same mistake and finds this thread :oops:

Thank you very much for your help.