Page 2 of 2

Re: sandybridge cpu - no vaapi

Posted: 2014/11/03 18:16:48
by intux
Thanks for the quick reply. And I did check cpu usage while the video was playing. The video was 1080p HD, and the cpu usage was between 40-50%. Is it normal? And Totem is such a retard player that it doesn't support vaapi? If so, what bad design to bundle it as the default player in the overall gnome stack!

Re: sandybridge cpu - no vaapi

Posted: 2014/11/03 19:18:20
by chemal
intux wrote:The video was 1080p HD, and the cpu usage was between 40-50%. Is it normal?
No, it means you're not using vaapi. It's either not working or not properly installed. What does "vainfo" say?
And Totem is such a retard player that it doesn't support vaapi?
It's a long known bug with putting filters in the chain that are incompatible with hw acceleration. It's definitely not fixed in the version that RH ships. If you let the gstreamer framework autoselect the filters (gst-launch ...) it works.

Re: sandybridge cpu - no vaapi

Posted: 2014/11/04 01:33:54
by intux
vainfo says:

libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.34 (libva 1.2.1)
vainfo: Driver version: Intel i965 driver - 1.2.1
vainfo: Supported profile and entrypoints
VAProfileNone : VAEntrypointVideoProc
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Simple : VAEntrypointEncSlice
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointEncSlice
VAProfileH264Baseline : VAEntrypointVLD
VAProfileH264Baseline : VAEntrypointEncSlice
VAProfileH264Main : VAEntrypointVLD
VAProfileH264Main : VAEntrypointEncSlice
VAProfileH264High : VAEntrypointVLD
VAProfileH264High : VAEntrypointEncSlice
VAProfileVC1Simple : VAEntrypointVLD
VAProfileVC1Main : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD

plz suggest me a version of totem with vaapi support that i can install on centos 7.

Re: sandybridge cpu - no vaapi

Posted: 2014/11/04 23:57:55
by chemal
I'm not a wonder worker. It's unlikely that C7 will ever see a more recent version of totem. Your best bet is to file a bugreport with RH.

If you're so much into totem and think you have vaapi working (doesn't seem so to me), then get the codecs from fluendo.com (20 EUR). They are supposed to work with every version of totem and support vaapi directly. Free alternatives have been pointed out to you.