sandybridge cpu - no vaapi

Issues related to applications and software problems
intux
Posts: 7
Joined: 2014/11/02 01:52:33

sandybridge cpu - no vaapi

Post by intux » 2014/11/02 02:01:39

hi, i've been using centos 7 from the day it rolled out. overall it's working fine, but i've been unable to use vaapi on my sandybridge (i3 3rd gen) machine. while playing video the cpu just spikes even upto 60% usage. I pulled in libva-intel-driver from epel and gstreamer1-vaapi package from nux, but it doesn't make any difference with or without them, no video acceleration at all. i'm a movie buff, please suggest me how get vaapi working properly on centos 7.

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: sandybridge cpu - no vaapi

Post by Vladi » 2014/11/02 06:49:29

intux wrote:hi, i've been using centos 7 from the day it rolled out. overall it's working fine, but i've been unable to use vaapi on my sandybridge (i3 3rd gen) machine. while playing video the cpu just spikes even upto 60% usage. I pulled in libva-intel-driver from epel and gstreamer1-vaapi package from nux, but it doesn't make any difference with or without them, no video acceleration at all. i'm a movie buff, please suggest me how get vaapi working properly on centos 7.
Do you have libvdpau-va-gl package installed?
I use smplayer for it.

intux
Posts: 7
Joined: 2014/11/02 01:52:33

Re: sandybridge cpu - no vaapi

Post by intux » 2014/11/02 13:20:00

Yes. Installed. No difference. cpu spikes to > 60% while playing hd video. Whereas on my centos 6.6 it never exceeds 10% with vaapi.

For your information, I want hardware accelerated video on i3 sandybridge graphics on an h68 motherboard. I believe vdpau has nothing to do with it, i might be wrong though. However, here's the list of packages installed on my machine related to vaapi:

gstreamer1-vaapi-0.5.9-2.el7.x86_64
libva-intel-driver-1.2.1-1.el7.nux.x86_64
libva-1.2.1-3.el7.x86_64
libvdpau-va-gl-0.3.2-1.el7.nux.x86_64
libvdpau-0.8-1.el7.x86_64

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: sandybridge cpu - no vaapi

Post by Vladi » 2014/11/02 16:56:33

intux wrote: I believe vdpau has nothing to do with it, i might be wrong though.
I dont know. Do you mean it is a nvidia thing?

I also have:

libva-vdpau-driver
vdpauinfo
Please install and test:

Code: Select all

vdapuinfo
I get:
vdpauinfo
display: :0.0 screen: 0
API version: 1
Information string: G3DVL VDPAU Driver Shared Library version 1.0

Video surface:

name width height types
-------------------------------------------
420 8192 8192 NV12
422 8192 8192 NV12
444 8192 8192 NV12

Decoder capabilities:

name level macbs width height
-------------------------------------------
MPEG1 16 9216 2048 1152
MPEG2_SIMPLE 16 9216 2048 1152
MPEG2_MAIN 16 9216 2048 1152
H264_BASELINE 16 9216 2048 1152
H264_MAIN 16 9216 2048 1152
H264_HIGH 16 9216 2048 1152
VC1_SIMPLE 16 9216 2048 1152
VC1_MAIN 16 9216 2048 1152
VC1_ADVANCED 16 9216 2048 1152
But i have amd/ati 4670! And with smplayer the hardware acceleration works. See this topic.

btw: you are lucky. I needed libvdpau_r600.so to be rebuild from fedora srpm. Where can i ask a centos version? :mrgreen:

chemal
Posts: 682
Joined: 2013/12/08 19:44:49

Re: sandybridge cpu - no vaapi

Post by chemal » 2014/11/02 18:20:56

@intux: Check with something like

Code: Select all

gst-launch-1.0 playbin uri=file:///home/joe/my-random-media-file.mpeg
and you should see vaapi acceleration working. Some players, e.g. totem, put filters in the gstreamer pipeline that are incompatible with hardware acceleration and so it never gets used. You might want to try another player: mplayer + smplayer + libvdpau-va-gl (all available from nux) would be my suggestion.

intux
Posts: 7
Joined: 2014/11/02 01:52:33

Re: sandybridge cpu - no vaapi

Post by intux » 2014/11/03 01:20:36

here's what i get:

gst-launch-1.0 playbin uri=2_States.mp4
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstURIDecodeBin:uridecodebin0: Invalid URI "2_States.mp4".
Additional debug info:
gsturidecodebin.c(1309): gen_source_element (): /GstPlayBin:playbin0/GstURIDecodeBin:uridecodebin0
Setting pipeline to NULL ...
Freeing pipeline ...

intux
Posts: 7
Joined: 2014/11/02 01:52:33

Re: sandybridge cpu - no vaapi

Post by intux » 2014/11/03 01:30:24

Vladi wrote:btw: you are lucky. I needed libvdpau_r600.so to be rebuild from fedora srpm. Where can i ask a centos version? :mrgreen:
I don't know. I don't have any discrete graphics such as AMD or Nvidia. I only have Intel onboard graphics HD 3000, i.e., sandybridge.

chemal
Posts: 682
Joined: 2013/12/08 19:44:49

Re: sandybridge cpu - no vaapi

Post by chemal » 2014/11/03 02:08:43

intux wrote:ERROR: from element /GstURIDecodeBin:uridecodebin0: Invalid URI "2_States.mp4".
It says "inavlid URI", because you didn't follow the syntax I indicated in the example above. URIs are not just filenames. They include a protocol and the full path.

intux
Posts: 7
Joined: 2014/11/02 01:52:33

Re: sandybridge cpu - no vaapi

Post by intux » 2014/11/03 14:42:31

Thanks for the info. Here's what I get now:

gst-launch-1.0 playbin uri=file:///data/Videos/Movies/2_States.mp4
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Redistribute latency...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstPulseSinkClock

Just this much and movie is being played.

Also, nautilus is unable to create thumbnails when gstreamer1-vaapi is installed. On removing this package thumbnail creation normal. BTW, I'm using ffmpegthumbnailer for thumbnail creation. Somebody with Sandybridge CPU plz check this issue.

chemal
Posts: 682
Joined: 2013/12/08 19:44:49

Re: sandybridge cpu - no vaapi

Post by chemal » 2014/11/03 18:09:07

intux wrote:Just this much and movie is being played.
What did you expect? This is a simple test. If you want to know whether vaapi acceleration is used or not, you have to look at the CPU load during playback.
Also, nautilus is unable to create thumbnails when gstreamer1-vaapi is installed.
Besides this simple test, gstreamer1-vaapi is a useless package anyway. If you have verified that vaapi acceleration works you can uninstall it, totem won't pick it up. You need another player.

Post Reply

Return to “CentOS 7 - Software Support”