Can't install Dia

Issues related to applications and software problems
Post Reply
climber
Posts: 6
Joined: 2014/06/27 19:00:04

Can't install Dia

Post by climber » 2014/10/27 16:14:28

Hi to all!

I tried to install Dia and got two errors:

Code: Select all

[root@localhost dima]# yum install dia
...
<skipped>
...
Error: Package: 1:dia-0.97.2-1.el6.rf.x86_64 (rpmforge)
           Requires: libEMF.so.1()(64bit)
Error: Package: 1:dia-0.97.2-1.el6.rf.x86_64 (rpmforge)
           Requires: libpython2.6.so.1.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I found that libEMF could be installed from epel repository. I have this repository, but when I tried to install libEMF, I got message "package not found, nothing to install". Then I found this package here: http://rpmfind.net/linux/rpm2html/searc ... ibEMF.so.1, but this site has package only for centOS 6.5, not for 7.0. I tried to istall libEMF from that source, but nothing changed. Now I have required file:

Code: Select all

[root@localhost dima]# find / -name libEMF.so.1
/usr/lib/libEMF.so.1
But when I try to install dia again, I receive the same error message as before. Also I have python 2.7 installed and I don't understand, what do I need to get libpython2.6.so.1.0.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Can't install Dia

Post by gerald_clark » 2014/10/27 16:49:41

1. You cannot use el6 repos with CentOS 7.
2. Rpmforge is not well maintained. You would be better off with epel and nux-dextop.

User avatar
Vladi
Posts: 128
Joined: 2014/08/22 01:25:43
Location: Nyíregyháza/Hungary/EU

Re: Can't install Dia

Post by Vladi » 2014/10/27 17:43:26

You need to compile it.
We have solved this problem earlier: link

Post Reply

Return to “CentOS 7 - Software Support”