Wine: Bad exe format

Issues related to applications and software problems
Post Reply
tkurgpold
Posts: 2
Joined: 2014/09/22 17:06:19

Wine: Bad exe format

Post by tkurgpold » 2014/09/22 17:11:40

Hello all,

I am fairly new to the world of CentOS, but have been using Linux off and on throughout the years, beginning with Ubuntu 8.04. Whenever I install a Linux distro, one of the first things I do is install Wine. I have never had issues running programs with Wine before, but CentOS seems to be screwing it up. I succesfully installed it via YUM, and after running 'wine [program]', I get the following error:

wine: Bad EXE format for H:\SA-MP\gta_sa.exe.

This is boggling my mind. Google has resulted in no help whatsoever. Have tried reinstalling multiple times, and compiling from source, all to no avail. I am at my wits end here.

User avatar
jyoung
Posts: 102
Joined: 2014/09/22 13:40:31
Location: Nashville, TN, USA

Re: Wine: Bad exe format

Post by jyoung » 2014/09/23 13:13:31

Are you trying to run a 64-bit application with 32-bit wine, or vice-versa?

Code: Select all

rpm -qa | grep wine
-- Jeremy --

tkurgpold
Posts: 2
Joined: 2014/09/22 17:06:19

Re: Wine: Bad exe format

Post by tkurgpold » 2014/09/28 17:00:30

jyoung wrote:Are you trying to run a 64-bit application with 32-bit wine, or vice-versa?

Code: Select all

rpm -qa | grep wine
As far as I know, it should work. I have used it on both 32 and 64 bit windows in the past.

Code: Select all

wine-symbol-fonts-1.7.22-1.el7.noarch
wine-common-1.7.22-1.el7.noarch
wine-fixedsys-fonts-1.7.22-1.el7.noarch
wine-wow-1.7.22-1.el7.x86_64
wine-fonts-1.7.22-1.el7.noarch
wine-pulseaudio-1.7.22-1.el7.x86_64
wine-desktop-1.7.22-1.el7.x86_64
wine-twain-1.7.22-1.el7.x86_64
wine-marlett-fonts-1.7.22-1.el7.noarch
wine-cms-1.7.22-1.el7.x86_64
wine-small-fonts-1.7.22-1.el7.noarch
wine-1.7.22-1.el7.x86_64
wine-core-1.7.22-1.el7.x86_64
wine-capi-1.7.22-1.el7.x86_64
wine-courier-fonts-1.7.22-1.el7.noarch
wine-openal-1.7.22-1.el7.x86_64
wine-tahoma-fonts-1.7.22-1.el7.noarch
wine-system-fonts-1.7.22-1.el7.noarch
wine-alsa-1.7.22-1.el7.x86_64
wine-ldap-1.7.22-1.el7.x86_64
wine-wingdings-fonts-1.7.22-1.el7.noarch
wine-filesystem-1.7.22-1.el7.noarch
wine-ms-sans-serif-fonts-1.7.22-1.el7.noarch

pghalliday
Posts: 1
Joined: 2014/11/16 10:54:18

Re: Wine: Bad exe format

Post by pghalliday » 2014/11/16 10:57:50

I'm having the same problem with

Code: Select all

winetricks mfc42
and a few others which output

Code: Select all

------------------------------------------------------
You are using a 64-bit WINEPREFIX. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Executing w_do_call mfc42
Executing load_mfc42
Executing wine /home/vagrant/.cache/winetricks/vcrun6/vc6redistsetup_deu.exe /T:C:\windows\Temp\_mfc42 /c
wine: Bad EXE format for Y:\vcrun6\vc6redistsetup_deu.exe.
------------------------------------------------------
Note: command 'wine /home/vagrant/.cache/winetricks/vcrun6/vc6redistsetup_deu.exe /T:C:\windows\Temp\_mfc42 /c' returned status 193.  Aborting.
------------------------------------------------------
This worked fine on a 64bit CentOS 6.4 installation.

Have you found a solution at all?

Post Reply

Return to “CentOS 7 - Software Support”